aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Catalyst-Plugin-StackTrace
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-01-11 17:12:59 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-01-11 17:12:59 +0000
commit14f8e44a8f111caca40b653f7c9ab327348e15d0 (patch)
treeb4bcd37f9bbf59d294e330455265e80d976ca4b0 /www/p5-Catalyst-Plugin-StackTrace
parente731f3836c5aa100b7045598dc03fad00d76d7be (diff)
downloadports-14f8e44a8f111caca40b653f7c9ab327348e15d0.tar.gz
ports-14f8e44a8f111caca40b653f7c9ab327348e15d0.zip
Notes
Diffstat (limited to 'www/p5-Catalyst-Plugin-StackTrace')
-rw-r--r--www/p5-Catalyst-Plugin-StackTrace/Makefile30
-rw-r--r--www/p5-Catalyst-Plugin-StackTrace/distinfo3
-rw-r--r--www/p5-Catalyst-Plugin-StackTrace/pkg-descr6
-rw-r--r--www/p5-Catalyst-Plugin-StackTrace/pkg-plist3
4 files changed, 42 insertions, 0 deletions
diff --git a/www/p5-Catalyst-Plugin-StackTrace/Makefile b/www/p5-Catalyst-Plugin-StackTrace/Makefile
new file mode 100644
index 000000000000..37273805881e
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-StackTrace/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: www/p5-Catalyst-Plugin-StackTrace
+# Date created: Jan 11 2006
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-StackTrace
+PORTVERSION= 0.02
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Catalyst
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= Display a stack trace on the debug screen
+
+BUILD_DEPENDS= p5-Catalyst>=5.61:${PORTSDIR}/www/p5-Catalyst \
+ p5-Devel-StackTrace>=0:${PORTSDIR}/devel/p5-Devel-StackTrace
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Catalyst::Plugin::StackTrace.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-Plugin-StackTrace/distinfo b/www/p5-Catalyst-Plugin-StackTrace/distinfo
new file mode 100644
index 000000000000..4f82fe12fc29
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-StackTrace/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-Plugin-StackTrace-0.02.tar.gz) = 849ed88f5c6300911b26f0403a89c87c
+SHA256 (Catalyst-Plugin-StackTrace-0.02.tar.gz) = a17ca3a0435f055887e86e874c508ca6340f6da91540bcbd7aea1fe62fce7375
+SIZE (Catalyst-Plugin-StackTrace-0.02.tar.gz) = 5187
diff --git a/www/p5-Catalyst-Plugin-StackTrace/pkg-descr b/www/p5-Catalyst-Plugin-StackTrace/pkg-descr
new file mode 100644
index 000000000000..914df0c9989c
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-StackTrace/pkg-descr
@@ -0,0 +1,6 @@
+This plugin will enhance the standard Catalyst debug screen by including
+a stack trace of your appliation up to the point where the error
+occurred. Each stack frame is displayed along with the package name,
+line number, file name, and code context surrounding the line number.
+
+WWW: http://search.cpan.org/dist/Catalyst-Plugin-StackTrace/
diff --git a/www/p5-Catalyst-Plugin-StackTrace/pkg-plist b/www/p5-Catalyst-Plugin-StackTrace/pkg-plist
new file mode 100644
index 000000000000..569d2b1d8c3d
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-StackTrace/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/Catalyst/Plugin/StackTrace.pm
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst 2>/dev/null || true