aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Catalyst-Runtime/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-11-06 18:58:46 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-11-06 18:58:46 +0000
commit9bb382602ce1db1efd6cbc61e34347e707c006ca (patch)
treecf171df8433360e1e3767a7c1e34815b010b0e54 /www/p5-Catalyst-Runtime/Makefile
parent96ccdb7d18ff6d4bb8d08ed77f629affb5b4e724 (diff)
downloadports-9bb382602ce1db1efd6cbc61e34347e707c006ca.tar.gz
ports-9bb382602ce1db1efd6cbc61e34347e707c006ca.zip
Notes
Diffstat (limited to 'www/p5-Catalyst-Runtime/Makefile')
-rw-r--r--www/p5-Catalyst-Runtime/Makefile63
1 files changed, 8 insertions, 55 deletions
diff --git a/www/p5-Catalyst-Runtime/Makefile b/www/p5-Catalyst-Runtime/Makefile
index cbe2d1d9f8b8..094a6e1b565e 100644
--- a/www/p5-Catalyst-Runtime/Makefile
+++ b/www/p5-Catalyst-Runtime/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= Catalyst-Runtime
-PORTVERSION= 5.90042
+PORTVERSION= 5.90050
CATEGORIES= www perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:JJNAPIORK
@@ -14,7 +14,6 @@ COMMENT= The Elegant MVC Web Application Framework (Runtime)
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-NO_STAGE= yes
# Do not add the following ports to TEST_DEPENDS to avoid cyclic dependencies in tinderbox:
# - devel/p5-Test-WWW-Mechanize-Catalyst
# - www/p5-Catalyst-Engine-PSGI
@@ -22,6 +21,7 @@ NO_STAGE= yes
#
# DEPENDS: Devel::InnerPackage was first released with perl v5.8.9 and removed from v5.19.0
BUILD_DEPENDS= p5-CGI-Simple>=1.109:${PORTSDIR}/www/p5-CGI-Simple \
+ p5-CGI-Struct>=0:${PORTSDIR}/www/p5-CGI-Struct \
p5-Catalyst-DispatchType-Regex>=5.90.021:${PORTSDIR}/www/p5-Catalyst-DispatchType-Regex \
p5-Class-C3-Adopt-NEXT>=0.07:${PORTSDIR}/devel/p5-Class-C3-Adopt-NEXT \
p5-Class-Data-Inheritable>=0:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
@@ -32,8 +32,11 @@ BUILD_DEPENDS= p5-CGI-Simple>=1.109:${PORTSDIR}/www/p5-CGI-Simple \
p5-HTTP-Body>=1.06:${PORTSDIR}/www/p5-HTTP-Body \
p5-HTTP-Message>=5.814:${PORTSDIR}/www/p5-HTTP-Message \
p5-HTTP-Request-AsCGI>=1.0:${PORTSDIR}/www/p5-HTTP-Request-AsCGI \
+ p5-Hash-MultiValue>=0:${PORTSDIR}/devel/p5-Hash-MultiValue \
+ p5-JSON-MaybeXS>=1:${PORTSDIR}/converters/p5-JSON-MaybeXS \
p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils \
p5-MRO-Compat>=0:${PORTSDIR}/devel/p5-MRO-Compat \
+ p5-Module-Pluggable>=4.7:${PORTSDIR}/devel/p5-Module-Pluggable \
p5-Moose>=2:${PORTSDIR}/devel/p5-Moose \
p5-MooseX-Emulate-Class-Accessor-Fast>=0.00903:${PORTSDIR}/devel/p5-MooseX-Emulate-Class-Accessor-Fast \
p5-MooseX-Getopt>=0.30:${PORTSDIR}/devel/p5-MooseX-Getopt \
@@ -47,77 +50,27 @@ BUILD_DEPENDS= p5-CGI-Simple>=1.109:${PORTSDIR}/www/p5-CGI-Simple \
p5-Plack-Middleware-ReverseProxy>=0.04:${PORTSDIR}/www/p5-Plack-Middleware-ReverseProxy \
p5-Plack-Test-ExternalServer>=0:${PORTSDIR}/www/p5-Plack-Test-ExternalServer \
p5-Safe-Isa>=0:${PORTSDIR}/devel/p5-Safe-Isa \
+ p5-Stream-Buffered>=0:${PORTSDIR}/devel/p5-Stream-Buffered \
p5-String-RewritePrefix>=0.004:${PORTSDIR}/textproc/p5-String-RewritePrefix \
p5-Sub-Exporter>=0:${PORTSDIR}/devel/p5-Sub-Exporter \
p5-Task-Weaken>=0:${PORTSDIR}/devel/p5-Task-Weaken \
p5-Text-SimpleTable>=0.03:${PORTSDIR}/textproc/p5-Text-SimpleTable \
p5-Tree-Simple>=1.15:${PORTSDIR}/devel/p5-Tree-Simple \
p5-Tree-Simple-VisitorFactory>=0:${PORTSDIR}/devel/p5-Tree-Simple-VisitorFactory \
- p5-Try-Tiny>=0:${PORTSDIR}/lang/p5-Try-Tiny \
+ p5-Try-Tiny>=0.17:${PORTSDIR}/lang/p5-Try-Tiny \
p5-URI>=1.36:${PORTSDIR}/net/p5-URI \
p5-libwww>=5.837:${PORTSDIR}/www/p5-libwww \
p5-namespace-autoclean>=0.09:${PORTSDIR}/devel/p5-namespace-autoclean \
p5-namespace-clean>=0.23:${PORTSDIR}/devel/p5-namespace-clean
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-IO-stringy>=0:${PORTSDIR}/devel/p5-IO-stringy \
- p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
+ p5-Test-Fatal>=0:${PORTSDIR}/devel/p5-Test-Fatal \
p5-Test-Without-Module>=0:${PORTSDIR}/devel/p5-Test-Without-Module \
p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML
USES= perl5
USE_PERL5= configure
-MAN1= catalyst.pl.1
-MAN3= Catalyst.3 \
- Catalyst::Action.3 \
- Catalyst::ActionChain.3 \
- Catalyst::ActionContainer.3 \
- Catalyst::ActionRole::HTTPMethods.3 \
- Catalyst::Base.3 \
- Catalyst::ClassData.3 \
- Catalyst::Component.3 \
- Catalyst::Component::ApplicationAttribute.3 \
- Catalyst::Component::ContextClosure.3 \
- Catalyst::Controller.3 \
- Catalyst::Delta.3 \
- Catalyst::DispatchType.3 \
- Catalyst::DispatchType::Chained.3 \
- Catalyst::DispatchType::Default.3 \
- Catalyst::DispatchType::Index.3 \
- Catalyst::DispatchType::Path.3 \
- Catalyst::Dispatcher.3 \
- Catalyst::Engine.3 \
- Catalyst::Engine::HTTP.3 \
- Catalyst::EngineLoader.3 \
- Catalyst::Exception.3 \
- Catalyst::Exception::Basic.3 \
- Catalyst::Exception::Detach.3 \
- Catalyst::Exception::Go.3 \
- Catalyst::Exception::Interface.3 \
- Catalyst::Log.3 \
- Catalyst::Model.3 \
- Catalyst::PSGI.3 \
- Catalyst::Plugin::Unicode::Encoding.3 \
- Catalyst::Request.3 \
- Catalyst::Request::Upload.3 \
- Catalyst::Response.3 \
- Catalyst::Runtime.3 \
- Catalyst::Script::CGI.3 \
- Catalyst::Script::Create.3 \
- Catalyst::Script::FastCGI.3 \
- Catalyst::Script::Server.3 \
- Catalyst::Script::Test.3 \
- Catalyst::ScriptRole.3 \
- Catalyst::ScriptRunner.3 \
- Catalyst::Stats.3 \
- Catalyst::Test.3 \
- Catalyst::Upgrading.3 \
- Catalyst::Utils.3 \
- Catalyst::View.3
-
-post-install:
- @${CAT} ${PKGDIR}/pkg-message
-
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 501800