aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Catalyst-View-GraphViz
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-02-19 19:59:35 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-02-19 19:59:35 +0000
commit7556ef8f9aa541720cc0a8e38b7ecd0aec7c0f6a (patch)
tree34c80db4ca91d8985f549ef744d1f8cb23f4f703 /www/p5-Catalyst-View-GraphViz
parent9f07c57763d83d01c264f2a4746d402804877247 (diff)
downloadports-7556ef8f9aa541720cc0a8e38b7ecd0aec7c0f6a.tar.gz
ports-7556ef8f9aa541720cc0a8e38b7ecd0aec7c0f6a.zip
Notes
Diffstat (limited to 'www/p5-Catalyst-View-GraphViz')
-rw-r--r--www/p5-Catalyst-View-GraphViz/Makefile34
-rw-r--r--www/p5-Catalyst-View-GraphViz/distinfo3
-rw-r--r--www/p5-Catalyst-View-GraphViz/pkg-descr3
-rw-r--r--www/p5-Catalyst-View-GraphViz/pkg-plist11
4 files changed, 51 insertions, 0 deletions
diff --git a/www/p5-Catalyst-View-GraphViz/Makefile b/www/p5-Catalyst-View-GraphViz/Makefile
new file mode 100644
index 000000000000..547ce86f272d
--- /dev/null
+++ b/www/p5-Catalyst-View-GraphViz/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: www/p5-Catalyst-View-GraphViz
+# Date created: 10 February 2006
+# Whom: Zach Thompson <hideo@lastamericanempire.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-View-GraphViz
+PORTVERSION= 0.05
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Catalyst
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hideo@lastamericanempire.com
+COMMENT= Catalyst::View::GraphViz - GraphViz View Class
+
+BUILD_DEPENDS= ${SITE_PERL}/Catalyst/Plugin/SubRequest.pm:${PORTSDIR}/www/p5-Catalyst-Plugin-SubRequest \
+ ${SITE_PERL}/GraphViz.pm:${PORTSDIR}/graphics/p5-GraphViz
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Catalyst::Helper::View::GraphView.3 \
+ Catalyst::Helper::View::GraphViz.3 \
+ Catalyst::View::GraphViz.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires Perl 5.8. Install lang/perl5.8, and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-View-GraphViz/distinfo b/www/p5-Catalyst-View-GraphViz/distinfo
new file mode 100644
index 000000000000..f0d0e30faf73
--- /dev/null
+++ b/www/p5-Catalyst-View-GraphViz/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-View-GraphViz-0.05.tar.gz) = d94ae0227f77a4e751b2767519081d79
+SHA256 (Catalyst-View-GraphViz-0.05.tar.gz) = 68d27f70bf945f6d8ed1281dbd60c22442ddc8cf25b2c26102a82035cd4330ae
+SIZE (Catalyst-View-GraphViz-0.05.tar.gz) = 6416
diff --git a/www/p5-Catalyst-View-GraphViz/pkg-descr b/www/p5-Catalyst-View-GraphViz/pkg-descr
new file mode 100644
index 000000000000..3de662e82fa7
--- /dev/null
+++ b/www/p5-Catalyst-View-GraphViz/pkg-descr
@@ -0,0 +1,3 @@
+This is the Catalyst view class for GraphViz.
+
+WWW: http://search.cpan.org/dist/Catalyst-View-GraphViz
diff --git a/www/p5-Catalyst-View-GraphViz/pkg-plist b/www/p5-Catalyst-View-GraphViz/pkg-plist
new file mode 100644
index 000000000000..e7514fb5dac2
--- /dev/null
+++ b/www/p5-Catalyst-View-GraphViz/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/Catalyst/Helper/View/GraphView.pm
+%%SITE_PERL%%/Catalyst/Helper/View/GraphViz.pm
+%%SITE_PERL%%/Catalyst/View/GraphViz.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/View/GraphViz/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/View/GraphViz
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/View
+@dirrmtry %%SITE_PERL%%/Catalyst/Helper/View
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst
+@dirrmtry %%SITE_PERL%%/Catalyst/Helper
+@dirrmtry %%SITE_PERL%%/Catalyst/View
+@dirrmtry %%SITE_PERL%%/Catalyst