aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Catalyst-View-TT/Makefile
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2005-05-07 14:24:53 +0000
committerLars Thegler <lth@FreeBSD.org>2005-05-07 14:24:53 +0000
commit55ece89566a404c28e0b125b4d2b275882317f45 (patch)
tree26d5345f137cd4cd7bb877c796e3f530ed08a763 /www/p5-Catalyst-View-TT/Makefile
parentbd361164201ef4468a7fb1d23d76b1e487c990a6 (diff)
downloadports-55ece89566a404c28e0b125b4d2b275882317f45.tar.gz
ports-55ece89566a404c28e0b125b4d2b275882317f45.zip
Notes
Diffstat (limited to 'www/p5-Catalyst-View-TT/Makefile')
-rw-r--r--www/p5-Catalyst-View-TT/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/www/p5-Catalyst-View-TT/Makefile b/www/p5-Catalyst-View-TT/Makefile
new file mode 100644
index 000000000000..ab647aaab99b
--- /dev/null
+++ b/www/p5-Catalyst-View-TT/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: www/p5-Catalyst-View-TT
+# Date created: 04 May 2005
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-View-TT
+PORTVERSION= 0.11
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/M/MR/MRAMBERG
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Template Toolkit view class for Catalyst
+
+BUILD_DEPENDS= ${SITE_PERL}/Catalyst.pm:${PORTSDIR}/www/p5-Catalyst \
+ ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit \
+ ${SITE_PERL}/Template/Timer.pm:${PORTSDIR}/www/p5-Template-Timer
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Catalyst::Helper::View::TT.3 \
+ Catalyst::View::TT.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+IGNORE= requires Perl 5.6. Install lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>