aboutsummaryrefslogtreecommitdiff
path: root/www/p5-CatalystX-InjectComponent
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2011-05-08 23:08:38 +0000
committerSteve Wills <swills@FreeBSD.org>2011-05-08 23:08:38 +0000
commit0fe1cdd74079473e7ee1c6b5db7a8aca73803320 (patch)
tree5fce39b9c4e524cbbffbe1ea944ea66db5f200e2 /www/p5-CatalystX-InjectComponent
parent38be3017513dabe2f5e6511eb363cb6d7fa0063e (diff)
downloadports-0fe1cdd74079473e7ee1c6b5db7a8aca73803320.tar.gz
ports-0fe1cdd74079473e7ee1c6b5db7a8aca73803320.zip
Notes
Diffstat (limited to 'www/p5-CatalystX-InjectComponent')
-rw-r--r--www/p5-CatalystX-InjectComponent/Makefile32
-rw-r--r--www/p5-CatalystX-InjectComponent/distinfo2
-rw-r--r--www/p5-CatalystX-InjectComponent/pkg-descr6
-rw-r--r--www/p5-CatalystX-InjectComponent/pkg-plist5
4 files changed, 45 insertions, 0 deletions
diff --git a/www/p5-CatalystX-InjectComponent/Makefile b/www/p5-CatalystX-InjectComponent/Makefile
new file mode 100644
index 000000000000..27c1ddcc8adb
--- /dev/null
+++ b/www/p5-CatalystX-InjectComponent/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-CatalystX-InjectComponent
+# Date created: 2011-05-08
+# Whom: Steve Wills <swills@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CatalystX-InjectComponent
+PORTVERSION= 0.024
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:RKRIMEN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Inject components into your Catalyst application
+
+BUILD_DEPENDS= p5-Catalyst-Runtime>=5.8:${PORTSDIR}/www/p5-Catalyst-Runtime \
+ p5-Class-Inspector>=0:${PORTSDIR}/devel/p5-Class-Inspector \
+ p5-Module-Pluggable>=0:${PORTSDIR}/devel/p5-Module-Pluggable \
+ p5-parent>=0:${PORTSDIR}/devel/p5-parent
+RUN_DEPENDS= p5-Catalyst-Runtime>=5.8:${PORTSDIR}/www/p5-Catalyst-Runtime \
+ p5-Class-Inspector>=0:${PORTSDIR}/devel/p5-Class-Inspector \
+ p5-Module-Pluggable>=0:${PORTSDIR}/devel/p5-Module-Pluggable \
+ p5-parent>=0:${PORTSDIR}/devel/p5-parent
+
+USE_PERL= yes
+PERL_CONFIGURE= yes
+
+MAN3= CatalystX::InjectComponent.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-CatalystX-InjectComponent/distinfo b/www/p5-CatalystX-InjectComponent/distinfo
new file mode 100644
index 000000000000..a51882425a9b
--- /dev/null
+++ b/www/p5-CatalystX-InjectComponent/distinfo
@@ -0,0 +1,2 @@
+SHA256 (CatalystX-InjectComponent-0.024.tar.gz) = 95ff2e9b26b161ea41eaf5581d9657758e9a1c2c7a290aac3e137f525732632c
+SIZE (CatalystX-InjectComponent-0.024.tar.gz) = 17414
diff --git a/www/p5-CatalystX-InjectComponent/pkg-descr b/www/p5-CatalystX-InjectComponent/pkg-descr
new file mode 100644
index 000000000000..4a9fe360e893
--- /dev/null
+++ b/www/p5-CatalystX-InjectComponent/pkg-descr
@@ -0,0 +1,6 @@
+CatalystX::InjectComponent will inject Controller, Model, and View components
+into your Catalyst application at setup (run)time. It does this by creating a
+new package on-the-fly, having that package extend the given component, and
+then having Catalyst setup the new component (via ->setup_component)
+
+WWW: http://search.cpan.org/dist/CatalystX-InjectComponent/
diff --git a/www/p5-CatalystX-InjectComponent/pkg-plist b/www/p5-CatalystX-InjectComponent/pkg-plist
new file mode 100644
index 000000000000..88a55bd9ac48
--- /dev/null
+++ b/www/p5-CatalystX-InjectComponent/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/CatalystX/InjectComponent.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/CatalystX/InjectComponent/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CatalystX/InjectComponent
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CatalystX
+@dirrmtry %%SITE_PERL%%/CatalystX