aboutsummaryrefslogtreecommitdiff
path: root/www/p5-CatalystX-Profile/Makefile
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2011-05-08 23:53:52 +0000
committerSteve Wills <swills@FreeBSD.org>2011-05-08 23:53:52 +0000
commit7f9f10fe289e63d1a71bf996717460d23c6f57c7 (patch)
tree4e43e8d57d211cc466c9b7549625b5827d683762 /www/p5-CatalystX-Profile/Makefile
parent0fe1cdd74079473e7ee1c6b5db7a8aca73803320 (diff)
downloadports-7f9f10fe289e63d1a71bf996717460d23c6f57c7.tar.gz
ports-7f9f10fe289e63d1a71bf996717460d23c6f57c7.zip
Notes
Diffstat (limited to 'www/p5-CatalystX-Profile/Makefile')
-rw-r--r--www/p5-CatalystX-Profile/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/www/p5-CatalystX-Profile/Makefile b/www/p5-CatalystX-Profile/Makefile
new file mode 100644
index 000000000000..1e509abf4ad0
--- /dev/null
+++ b/www/p5-CatalystX-Profile/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-CatalystX-Profile
+# Date created: 2011-05-08
+# Whom: Steve Wills <swills@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CatalystX-Profile
+PORTVERSION= 0.01
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:CYCLES
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Profile your Catalyst application with Devel::NYTProf
+
+BUILD_DEPENDS= p5-Catalyst-Runtime>=5.80020:${PORTSDIR}/www/p5-Catalyst-Runtime \
+ p5-CatalystX-InjectComponent>=0.024:${PORTSDIR}/www/p5-CatalystX-InjectComponent \
+ devel/p5-Devel-NYTProf>=3.01:${PORTSDIR}/devel/p5-Devel-NYTProf \
+ p5-Moose>=0.93:${PORTSDIR}/devel/p5-Moose \
+ p5-namespace-autoclean>=0:${PORTSDIR}/devel/p5-namespace-autoclean
+RUN_DEPENDS= p5-Catalyst-Runtime>=5.80020:${PORTSDIR}/www/p5-Catalyst-Runtime \
+ p5-CatalystX-InjectComponent>=0.024:${PORTSDIR}/www/p5-CatalystX-InjectComponent \
+ devel/p5-Devel-NYTProf>=3.01:${PORTSDIR}/devel/p5-Devel-NYTProf \
+ p5-Moose>=0.93:${PORTSDIR}/devel/p5-Moose \
+ p5-namespace-autoclean>=0:${PORTSDIR}/devel/p5-namespace-autoclean
+
+USE_PERL= yes
+PERL_CONFIGURE= yes
+
+MAN3= CatalystX::Profile.3 CatalystX::Profile::Controller::ControlProfiling.3
+
+.include <bsd.port.mk>