aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Dancer-Plugin-ExtDirect
diff options
context:
space:
mode:
authorTom Judge <tj@FreeBSD.org>2013-09-04 18:04:48 +0000
committerTom Judge <tj@FreeBSD.org>2013-09-04 18:04:48 +0000
commitbcaced2c93b58d27ca266602f4049df6ba6becb3 (patch)
tree5f9c0130e92c0a26379aa02a51c1003e9eb4c500 /www/p5-Dancer-Plugin-ExtDirect
parentab28ac5c2a8bb7d5684e6efca24c5cf897cb396f (diff)
downloadports-bcaced2c93b58d27ca266602f4049df6ba6becb3.tar.gz
ports-bcaced2c93b58d27ca266602f4049df6ba6becb3.zip
Notes
Diffstat (limited to 'www/p5-Dancer-Plugin-ExtDirect')
-rw-r--r--www/p5-Dancer-Plugin-ExtDirect/Makefile25
-rw-r--r--www/p5-Dancer-Plugin-ExtDirect/distinfo2
-rw-r--r--www/p5-Dancer-Plugin-ExtDirect/pkg-descr3
-rw-r--r--www/p5-Dancer-Plugin-ExtDirect/pkg-plist7
4 files changed, 37 insertions, 0 deletions
diff --git a/www/p5-Dancer-Plugin-ExtDirect/Makefile b/www/p5-Dancer-Plugin-ExtDirect/Makefile
new file mode 100644
index 000000000000..4921a42734e5
--- /dev/null
+++ b/www/p5-Dancer-Plugin-ExtDirect/Makefile
@@ -0,0 +1,25 @@
+# Created by: Tom Judge <tj@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Dancer-Plugin-ExtDirect
+PORTVERSION= 1.03
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tj@FreeBSD.org
+COMMENT= Dancer plugin for implementing ExtDirect APIs
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Dancer>=1.2001:${PORTSDIR}/www/p5-Dancer \
+ p5-JSON>=0:${PORTSDIR}/converters/p5-JSON
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+
+MAN3= Dancer::Plugin::ExtDirect.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Dancer-Plugin-ExtDirect/distinfo b/www/p5-Dancer-Plugin-ExtDirect/distinfo
new file mode 100644
index 000000000000..a17f053f8d7b
--- /dev/null
+++ b/www/p5-Dancer-Plugin-ExtDirect/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Dancer-Plugin-ExtDirect-1.03.tar.gz) = 4c6f5d8033a39c9687a9cf99902976788cc1e966814fe1871e84b2fb206e02d7
+SIZE (Dancer-Plugin-ExtDirect-1.03.tar.gz) = 11720
diff --git a/www/p5-Dancer-Plugin-ExtDirect/pkg-descr b/www/p5-Dancer-Plugin-ExtDirect/pkg-descr
new file mode 100644
index 000000000000..6c2a0cb5179c
--- /dev/null
+++ b/www/p5-Dancer-Plugin-ExtDirect/pkg-descr
@@ -0,0 +1,3 @@
+Dancer plugin which provides an easy way implement ExtDirect APIs.
+
+WWW: http://search.cpan.org/dist/Dancer-Plugin-ExtDirect/
diff --git a/www/p5-Dancer-Plugin-ExtDirect/pkg-plist b/www/p5-Dancer-Plugin-ExtDirect/pkg-plist
new file mode 100644
index 000000000000..4207ab2a4fd5
--- /dev/null
+++ b/www/p5-Dancer-Plugin-ExtDirect/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer/Plugin/ExtDirect/.packlist
+%%SITE_PERL%%/Dancer/Plugin/ExtDirect.pm
+@dirrmtry %%SITE_PERL%%/Dancer/Plugin
+@dirrmtry %%SITE_PERL%%/Dancer
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer/Plugin/ExtDirect
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer/Plugin
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer