aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Dancer-Plugin-Feed/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2011-03-02 03:33:14 +0000
committerWen Heping <wen@FreeBSD.org>2011-03-02 03:33:14 +0000
commitb89040770a4db3115c899767399840607115a9ed (patch)
tree5311d57622589b123467ad07e188f29f89e21416 /www/p5-Dancer-Plugin-Feed/Makefile
parentc7c94a5738b9ba3711bfb4a50f01efe5600ef4e9 (diff)
Notes
Diffstat (limited to 'www/p5-Dancer-Plugin-Feed/Makefile')
-rw-r--r--www/p5-Dancer-Plugin-Feed/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/www/p5-Dancer-Plugin-Feed/Makefile b/www/p5-Dancer-Plugin-Feed/Makefile
new file mode 100644
index 000000000000..ac1d6efb90d9
--- /dev/null
+++ b/www/p5-Dancer-Plugin-Feed/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: Dancer-Plugin-Feed
+# Date created: 01 March 2011
+# Whom: Grzegorz Blach <magik@roorback.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Dancer-Plugin-Feed
+PORTVERSION= 0.1
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/H/HO/HOBBESTIG/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= magik@roorback.net
+COMMENT= Dancer plugin for generating RSS or Atom feeds
+
+RUN_DEPENDS= p5-Dancer>=1.175:${PORTSDIR}/www/p5-Dancer \
+ p5-XML-Feed>0:${PORTSDIR}/textproc/p5-XML-Feed
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Dancer::Plugin::Feed.3
+
+.include <bsd.port.mk>