aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Dancer-Plugin-RPC
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-06-02 19:57:21 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-06-02 19:57:21 +0000
commit6231b45dd3d774b5d72580c05ddc33404b57a253 (patch)
tree4d87dda49225797de2120e1f6818c22308b5a2ee /www/p5-Dancer-Plugin-RPC
parent914807748e3a29ce43cb640ef2d485b53f6958a7 (diff)
downloadports-6231b45dd3d774b5d72580c05ddc33404b57a253.tar.gz
ports-6231b45dd3d774b5d72580c05ddc33404b57a253.zip
Notes
Diffstat (limited to 'www/p5-Dancer-Plugin-RPC')
-rw-r--r--www/p5-Dancer-Plugin-RPC/Makefile29
-rw-r--r--www/p5-Dancer-Plugin-RPC/distinfo3
-rw-r--r--www/p5-Dancer-Plugin-RPC/pkg-descr19
-rw-r--r--www/p5-Dancer-Plugin-RPC/pkg-plist14
4 files changed, 65 insertions, 0 deletions
diff --git a/www/p5-Dancer-Plugin-RPC/Makefile b/www/p5-Dancer-Plugin-RPC/Makefile
new file mode 100644
index 000000000000..d94f537c23eb
--- /dev/null
+++ b/www/p5-Dancer-Plugin-RPC/Makefile
@@ -0,0 +1,29 @@
+# Created by: Henk van Oers <hvo.pm@xs4all.nl>
+# $FreeBSD$
+
+PORTNAME= Dancer-Plugin-RPC
+PORTVERSION= 1.00
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:ABELTJE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hvo.pm@xs4all.nl
+COMMENT= Configure endpoints for XML and/or JSON RPC routes
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+RUN_DEPENDS= \
+ p5-Dancer>=1.3202:www/p5-Dancer \
+ p5-Plack>=1.0002:www/p5-Plack \
+ p5-Params-Validate>=1.0:devel/p5-Params-Validate \
+ p5-JSON>=2.0:converters/p5-JSON \
+ p5-RPC-XML>=0.79:net/p5-RPC-XML
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+TEST_DEPENDS=p5-Test-Fatal>0.010:devel/p5-Test-Fatal
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/www/p5-Dancer-Plugin-RPC/distinfo b/www/p5-Dancer-Plugin-RPC/distinfo
new file mode 100644
index 000000000000..719f657a5d8c
--- /dev/null
+++ b/www/p5-Dancer-Plugin-RPC/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1463556230
+SHA256 (Dancer-Plugin-RPC-1.00.tar.gz) = 785c99c54fa93650f3bbd3811c3e7e67ff113071a7508a3c7a46414ec3100482
+SIZE (Dancer-Plugin-RPC-1.00.tar.gz) = 13935
diff --git a/www/p5-Dancer-Plugin-RPC/pkg-descr b/www/p5-Dancer-Plugin-RPC/pkg-descr
new file mode 100644
index 000000000000..d5b48a5b1d90
--- /dev/null
+++ b/www/p5-Dancer-Plugin-RPC/pkg-descr
@@ -0,0 +1,19 @@
+This module contains two plugins for Dancer: Dancer::Plugin::RPC::XMLRPC
+and Dancer::Plugin::RPC::JSONRPC. They are plugins rather than
+Plack::Middleware.
+
+Dancer::Plugin::RPC::XMLRPC
+
+This plugin exposes the new keyword "xmlrpc" that is followed by 2
+arguments: the endpoint and the arguments to configure the xmlrpc-calls
+at this endpoint.
+
+Dancer::Plugin::RPC::JSONRPC
+
+This plugin exposes the new keyword "jsonrpc" that is followed by
+2 arguments: the endpoint and the arguments to configure the
+jsonrpc-calls at this endpoint.
+
+See the /t dir for examples (until some tutorial exists)
+
+WWW: https://metacpan.org/pod/Dancer::Plugin::RPC
diff --git a/www/p5-Dancer-Plugin-RPC/pkg-plist b/www/p5-Dancer-Plugin-RPC/pkg-plist
new file mode 100644
index 000000000000..388c9d08aee5
--- /dev/null
+++ b/www/p5-Dancer-Plugin-RPC/pkg-plist
@@ -0,0 +1,14 @@
+%%SITE_PERL%%/Dancer/Plugin/RPC.pm
+%%SITE_PERL%%/Dancer/Plugin/RPC/JSONRPC.pm
+%%SITE_PERL%%/Dancer/Plugin/RPC/XMLRPC.pm
+%%SITE_PERL%%/Dancer/RPCPlugin/CallbackResult.pm
+%%SITE_PERL%%/Dancer/RPCPlugin/DispatchFromConfig.pm
+%%SITE_PERL%%/Dancer/RPCPlugin/DispatchFromPod.pm
+%%SITE_PERL%%/Dancer/RPCPlugin/DispatchItem.pm
+%%PERL5_MAN3%%/Dancer::Plugin::RPC.3.gz
+%%PERL5_MAN3%%/Dancer::Plugin::RPC::JSONRPC.3.gz
+%%PERL5_MAN3%%/Dancer::Plugin::RPC::XMLRPC.3.gz
+%%PERL5_MAN3%%/Dancer::RPCPlugin::CallbackResult.3.gz
+%%PERL5_MAN3%%/Dancer::RPCPlugin::DispatchFromConfig.3.gz
+%%PERL5_MAN3%%/Dancer::RPCPlugin::DispatchFromPod.3.gz
+%%PERL5_MAN3%%/Dancer::RPCPlugin::DispatchItem.3.gz