aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Dancer-Template-Xslate/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2011-11-09 09:09:28 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2011-11-09 09:09:28 +0000
commite281ec1426732282605ee099e3c2c6b0a8fd7dcd (patch)
tree0ec0568bc9b5a9addc042d6cc86f41c500f19186 /www/p5-Dancer-Template-Xslate/Makefile
parent55c0bc0a022af1ee4cdd5ce4b06fdfdbebfac584 (diff)
downloadports-e281ec1426732282605ee099e3c2c6b0a8fd7dcd.tar.gz
ports-e281ec1426732282605ee099e3c2c6b0a8fd7dcd.zip
Notes
Diffstat (limited to 'www/p5-Dancer-Template-Xslate/Makefile')
-rw-r--r--www/p5-Dancer-Template-Xslate/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/www/p5-Dancer-Template-Xslate/Makefile b/www/p5-Dancer-Template-Xslate/Makefile
new file mode 100644
index 000000000000..5147bc1dd8ab
--- /dev/null
+++ b/www/p5-Dancer-Template-Xslate/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: Dancer-Template-Xslate
+# Date created: 23 October 2011
+# Whom: Grzegorz Blach <magik@roorback.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Dancer-Template-Xslate
+PORTVERSION= 0.01
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:FRANCKC
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= magik@roorback.net
+COMMENT= Text::Xslate wrapper for Dancer
+
+RUN_DEPENDS= p5-Dancer>0:${PORTSDIR}/www/p5-Dancer \
+ p5-Text-Xslate>0:${PORTSDIR}/textproc/p5-Text-Xslate
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Dancer::Template::Xslate.3
+
+post-patch:
+ ${RM} ${WRKSRC}/lib/Dancer/Template/Xslate.pm.orig
+
+.include <bsd.port.mk>