aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Dancer/Makefile
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2010-11-20 13:51:38 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2010-11-20 13:51:38 +0000
commit02c6e6b485454dc3f5a27cbc887d9e4aaf376a36 (patch)
tree24f82e26d2f852a599c2f158aa5381e369c8d8a8 /www/p5-Dancer/Makefile
parent8b8576518bb85c96196f1091a322707787ec0230 (diff)
downloadports-02c6e6b485454dc3f5a27cbc887d9e4aaf376a36.tar.gz
ports-02c6e6b485454dc3f5a27cbc887d9e4aaf376a36.zip
Notes
Diffstat (limited to 'www/p5-Dancer/Makefile')
-rw-r--r--www/p5-Dancer/Makefile20
1 files changed, 17 insertions, 3 deletions
diff --git a/www/p5-Dancer/Makefile b/www/p5-Dancer/Makefile
index 65fdc7519338..81ea02681e99 100644
--- a/www/p5-Dancer/Makefile
+++ b/www/p5-Dancer/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Dancer
-PORTVERSION= 1.176
+PORTVERSION= 1.2000
CATEGORIES= www perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= ../../authors/id/X/XS/XSAWYERX
@@ -16,7 +16,8 @@ MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Perl extension for minimal-effort oriented web application framework
RUN_DEPENDS= \
- p5-HTTP-Body>0:${PORTSDIR}/www/p5-HTTP-Body \
+ p5-libwww>0:${PORTSDIR}/www/p5-libwww \
+ p5-HTTP-Body>=1.07:${PORTSDIR}/www/p5-HTTP-Body \
p5-HTTP-Server-Simple-PSGI>=0.11:${PORTSDIR}/www/p5-HTTP-Server-Simple-PSGI \
p5-MIME-Types>0:${PORTSDIR}/mail/p5-MIME-Types \
p5-URI>0:${PORTSDIR}/net/p5-URI
@@ -37,20 +38,30 @@ MAN3= Dancer.3 \
Dancer::Config.3 \
Dancer::Cookbook.3 \
Dancer::Cookie.3 \
+ Dancer::Cookies.3 \
Dancer::Deployment.3 \
+ Dancer::Development.3 \
Dancer::Engine.3 \
Dancer::Error.3 \
Dancer::FileUtils.3 \
Dancer::HTTP.3 \
+ Dancer::Introduction.3 \
Dancer::Logger.3 \
+ Dancer::Logger::Abstract.3 \
+ Dancer::Logger::Console.3 \
+ Dancer::Logger::File.3 \
Dancer::ModuleLoader.3 \
+ Dancer::Object.3 \
Dancer::Plugin.3 \
+ Dancer::Plugin::Ajax.3 \
+ Dancer::Plugins.3 \
Dancer::Request.3 \
Dancer::Request::Upload.3 \
Dancer::Route::Cache.3 \
Dancer::Serializer.3 \
Dancer::Serializer::JSON.3 \
Dancer::Serializer::Mutable.3 \
+ Dancer::Serializer::XML.3 \
Dancer::Serializer::YAML.3 \
Dancer::Session.3 \
Dancer::Session::Abstract.3 \
@@ -59,6 +70,9 @@ MAN3= Dancer.3 \
Dancer::Template.3 \
Dancer::Template::Abstract.3 \
Dancer::Template::Simple.3 \
- Dancer::Template::TemplateToolkit.3
+ Dancer::Template::TemplateToolkit.3 \
+ Dancer::Test.3 \
+ Dancer::Timer.3 \
+ Dancer::Tutorial.3
.include <bsd.port.mk>