aboutsummaryrefslogtreecommitdiff
path: root/www/p5-FCGI-Async
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-06-14 03:55:31 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-06-14 03:55:31 +0000
commita3c88a83cf64d1a36dc3495c65e93a36420fcba4 (patch)
tree64acc111a2c4032cd8cefb7da2e8eee3e6d74a01 /www/p5-FCGI-Async
parente2d1f240ef3c137c3752d45ab0e8c59ddf31d898 (diff)
downloadports-a3c88a83cf64d1a36dc3495c65e93a36420fcba4.tar.gz
ports-a3c88a83cf64d1a36dc3495c65e93a36420fcba4.zip
Notes
Diffstat (limited to 'www/p5-FCGI-Async')
-rw-r--r--www/p5-FCGI-Async/Makefile24
-rw-r--r--www/p5-FCGI-Async/distinfo3
-rw-r--r--www/p5-FCGI-Async/pkg-descr5
-rw-r--r--www/p5-FCGI-Async/pkg-plist11
4 files changed, 43 insertions, 0 deletions
diff --git a/www/p5-FCGI-Async/Makefile b/www/p5-FCGI-Async/Makefile
new file mode 100644
index 000000000000..280c3efe2b3a
--- /dev/null
+++ b/www/p5-FCGI-Async/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-FCGI-Async
+# Date created: 2007-06-10
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= FCGI-Async
+PORTVERSION= 0.10
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= FCGI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Module to allow use of FastCGI asynchronously
+
+RUN_DEPENDS= ${SITE_PERL}/IO/Async/Buffer.pm:${PORTSDIR}/devel/p5-IO-Async
+
+PERL_CONFIGURE= yes
+
+MAN3= FCGI::Async.3 FCGI::Async::Constants.3 FCGI::Async::Request.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-FCGI-Async/distinfo b/www/p5-FCGI-Async/distinfo
new file mode 100644
index 000000000000..bb168702f130
--- /dev/null
+++ b/www/p5-FCGI-Async/distinfo
@@ -0,0 +1,3 @@
+MD5 (FCGI-Async-0.10.tar.gz) = c86c07cfb0577bd7ca6f0ea5480a4b87
+SHA256 (FCGI-Async-0.10.tar.gz) = 47797afd88b1febb7bee706b54c5528ab2b04348e8d740f7540f382ec3842f7e
+SIZE (FCGI-Async-0.10.tar.gz) = 24247
diff --git a/www/p5-FCGI-Async/pkg-descr b/www/p5-FCGI-Async/pkg-descr
new file mode 100644
index 000000000000..007670f8c2b6
--- /dev/null
+++ b/www/p5-FCGI-Async/pkg-descr
@@ -0,0 +1,5 @@
+This module allows a program to respond to FastCGI requests using an
+asynchronous model. It is based on IO::Async and will fully interact
+with any program using this base.
+
+WWW: http://search.cpan.org/dist/FCGI-Async/
diff --git a/www/p5-FCGI-Async/pkg-plist b/www/p5-FCGI-Async/pkg-plist
new file mode 100644
index 000000000000..9dc876067b77
--- /dev/null
+++ b/www/p5-FCGI-Async/pkg-plist
@@ -0,0 +1,11 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/FCGI/Async/.packlist
+%%SITE_PERL%%/FCGI/Async.pm
+%%SITE_PERL%%/FCGI/Async/Constants.pm
+%%SITE_PERL%%/FCGI/Async/Request.pm
+%%SITE_PERL%%/FCGI/Async/BuildParse.pm
+%%SITE_PERL%%/FCGI/Async/ClientConnection.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/FCGI/Async
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/FCGI
+@dirrmtry %%SITE_PERL%%/FCGI/Async
+@dirrmtry %%SITE_PERL%%/FCGI