aboutsummaryrefslogtreecommitdiff
path: root/www/p5-FCGI
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2011-08-23 12:18:06 +0000
committerAndrej Zverev <az@FreeBSD.org>2011-08-23 12:18:06 +0000
commitec4d2e2c6db234b65b748216463789fe44f38b98 (patch)
tree1357e6bdf0293c0dd3cc6168b093d59095e17c9a /www/p5-FCGI
parentb556daeb839d8cdd98d8386222d5f339d074a383 (diff)
Notes
Diffstat (limited to 'www/p5-FCGI')
-rw-r--r--www/p5-FCGI/Makefile37
-rw-r--r--www/p5-FCGI/distinfo2
-rw-r--r--www/p5-FCGI/pkg-descr8
-rw-r--r--www/p5-FCGI/pkg-plist5
4 files changed, 52 insertions, 0 deletions
diff --git a/www/p5-FCGI/Makefile b/www/p5-FCGI/Makefile
new file mode 100644
index 000000000000..922e2b205374
--- /dev/null
+++ b/www/p5-FCGI/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: p5-FCGI
+# Date created: October 27th 1999
+# Whom: Kelly Yancey <kbyanc@posi.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= FCGI
+PORTVERSION= 0.73
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:FLORA
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Modules for perl5, for enabling FastCGI support in CGI scripts
+
+OPTIONS= PURE_PERL "Build pure Perl version (experimental)" off
+
+# XXX: fcgi.0 is missing FCGX_Detach, see ports/149755
+#LIB_DEPENDS= fcgi.0:${PORTSDIR}/www/fcgi
+#CONFIGURE_ARGS+= --use-installed=${LOCALBASE}
+
+PERL_CONFIGURE= yes
+
+MAN3= FCGI.3
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_PURE_PERL)
+CONFIGURE_ARGS+=--pure-perl
+PLIST_SUB= PURE_PERL="@comment "
+.else
+PLIST_SUB= PURE_PERL=""
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/p5-FCGI/distinfo b/www/p5-FCGI/distinfo
new file mode 100644
index 000000000000..afdda384f979
--- /dev/null
+++ b/www/p5-FCGI/distinfo
@@ -0,0 +1,2 @@
+SHA256 (FCGI-0.73.tar.gz) = 08fee08b2d0766a6e87ead24db6b207829fdb29f4008b2d550e4a42e530384ed
+SIZE (FCGI-0.73.tar.gz) = 96250
diff --git a/www/p5-FCGI/pkg-descr b/www/p5-FCGI/pkg-descr
new file mode 100644
index 000000000000..e068d20dde0e
--- /dev/null
+++ b/www/p5-FCGI/pkg-descr
@@ -0,0 +1,8 @@
+This the FCGI module for perl5 which enables CGI scripts to take
+advantage of servers that are FastCGI-enabled. This module does not abstract
+the writing of CGIs themselves, for that you should refer to the p5-CGI
+module. For more information about FastCGI, the performance enhancements it
+offers, and how to write scripts using it, visit their web site at
+http://www.fastcgi.com/
+
+WWW: http://search.cpan.org/dist/FCGI/
diff --git a/www/p5-FCGI/pkg-plist b/www/p5-FCGI/pkg-plist
new file mode 100644
index 000000000000..7d9434ff4309
--- /dev/null
+++ b/www/p5-FCGI/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/FCGI.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/FCGI/.packlist
+%%PURE_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/FCGI/FCGI.so
+%%PURE_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/FCGI/FCGI.bs
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/FCGI