aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Feed-Find
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2005-07-30 15:34:24 +0000
committerLars Thegler <lth@FreeBSD.org>2005-07-30 15:34:24 +0000
commitac8a437e92c7910bbfb0f36252f91ed82637bf3a (patch)
treef3ca10ea34c0db7aafe1d9f686720ac4c182ce45 /www/p5-Feed-Find
parentf696d5c806948956180d38cd1b337ae4ab3836de (diff)
downloadports-ac8a437e92c7910bbfb0f36252f91ed82637bf3a.tar.gz
ports-ac8a437e92c7910bbfb0f36252f91ed82637bf3a.zip
Notes
Diffstat (limited to 'www/p5-Feed-Find')
-rw-r--r--www/p5-Feed-Find/Makefile32
-rw-r--r--www/p5-Feed-Find/distinfo2
-rw-r--r--www/p5-Feed-Find/pkg-descr4
-rw-r--r--www/p5-Feed-Find/pkg-plist2
4 files changed, 40 insertions, 0 deletions
diff --git a/www/p5-Feed-Find/Makefile b/www/p5-Feed-Find/Makefile
new file mode 100644
index 000000000000..67668edc7cf1
--- /dev/null
+++ b/www/p5-Feed-Find/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: www/p5-Feed-Find
+# Date created: 28 July 2005
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Feed-Find
+PORTVERSION= 0.05
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/B/BT/BTROTT
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Syndication feed auto-discovery
+
+BUILD_DEPENDS= ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser \
+ ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/Class/ErrorHandler.pm:${PORTSDIR}/devel/p5-Class-ErrorHandler
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Feed::Find.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires Perl 5.6 or newer. Install lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-Feed-Find/distinfo b/www/p5-Feed-Find/distinfo
new file mode 100644
index 000000000000..6ad888edcdef
--- /dev/null
+++ b/www/p5-Feed-Find/distinfo
@@ -0,0 +1,2 @@
+MD5 (Feed-Find-0.05.tar.gz) = f4b8b5d6458b6e5db57aef4d05d74462
+SIZE (Feed-Find-0.05.tar.gz) = 16299
diff --git a/www/p5-Feed-Find/pkg-descr b/www/p5-Feed-Find/pkg-descr
new file mode 100644
index 000000000000..75785088a537
--- /dev/null
+++ b/www/p5-Feed-Find/pkg-descr
@@ -0,0 +1,4 @@
+Feed::Find implements feed auto-discovery for finding syndication
+feeds, given a URI.
+
+WWW: http://search.cpan.org/dist/Feed-Find
diff --git a/www/p5-Feed-Find/pkg-plist b/www/p5-Feed-Find/pkg-plist
new file mode 100644
index 000000000000..77cdebeb053d
--- /dev/null
+++ b/www/p5-Feed-Find/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Feed/Find.pm
+@unexec rmdir %D/%%SITE_PERL%%/Feed 2>/dev/null || true