aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Feersum
diff options
context:
space:
mode:
authorFrederic Culot <culot@FreeBSD.org>2011-02-13 10:46:07 +0000
committerFrederic Culot <culot@FreeBSD.org>2011-02-13 10:46:07 +0000
commit94e5787cf4a158437aa6bd758530d5ac798e2e28 (patch)
tree9bae5b95f43938905a3dd46783d1386bbbda265e /www/p5-Feersum
parent23218ce92188058a2be46c77fd2a0c30a1cc3fa9 (diff)
Notes
Diffstat (limited to 'www/p5-Feersum')
-rw-r--r--www/p5-Feersum/Makefile34
-rw-r--r--www/p5-Feersum/distinfo2
-rw-r--r--www/p5-Feersum/pkg-descr12
-rw-r--r--www/p5-Feersum/pkg-plist14
4 files changed, 62 insertions, 0 deletions
diff --git a/www/p5-Feersum/Makefile b/www/p5-Feersum/Makefile
new file mode 100644
index 000000000000..2c48c9fd5b78
--- /dev/null
+++ b/www/p5-Feersum/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: Feersum
+# Date created: 2010-12-20
+# Whom: Grzegorz Blach <magik@roorback.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Feersum
+PORTVERSION= 1.001
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/S/ST/STASH
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= magik@roorback.net
+COMMENT= A PSGI engine for Perl based on EV/libev
+
+RUN_DEPENDS= p5-Plack>=0.9950:${PORTSDIR}/www/p5-Plack \
+ p5-EV>=4.0:${PORTSDIR}/devel/p5-EV \
+ p5-AnyEvent>=5.261:${PORTSDIR}/devel/p5-AnyEvent \
+ p5-Guard>=1.012:${PORTSDIR}/devel/p5-Guard \
+ p5-Scalar-List-Utils>=1.19:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ p5-Test-Simple>=0.94:${PORTSDIR}/devel/p5-Test-Simple \
+ p5-Test-Fatal>=0.003:${PORTSDIR}/devel/p5-Test-Fatal \
+ p5-Test-TCP>=1.06:${PORTSDIR}/devel/p5-Test-TCP
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= feersum.1
+MAN3= Plack::Handler::Feersum.3 Feersum.3 Feersum::Runner.3 \
+ Feersum::Connection.3 Feersum::Connection::Handle.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Feersum/distinfo b/www/p5-Feersum/distinfo
new file mode 100644
index 000000000000..042bbecc2967
--- /dev/null
+++ b/www/p5-Feersum/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Feersum-1.001.tar.gz) = 7bf941d9995dc0cf826715dbeb1d353330b3c0f59d680ae37cd0c75df1f51415
+SIZE (Feersum-1.001.tar.gz) = 99741
diff --git a/www/p5-Feersum/pkg-descr b/www/p5-Feersum/pkg-descr
new file mode 100644
index 000000000000..1eba397c4b28
--- /dev/null
+++ b/www/p5-Feersum/pkg-descr
@@ -0,0 +1,12 @@
+Feersum is an HTTP server built on EV. It fully supports the PSGI 1.03 spec
+including the psgi.streaming interface and is compatible with Plack. PSGI 1.1,
+which has yet to be published formally, is also supported. Feersum also has
+its own "native" interface which is similar in a lot of ways to PSGI, but is
+not compatible with PSGI or PSGI middleware.
+
+Feersum uses a single-threaded, event-based programming architecture to scale
+and can handle many concurrent connections efficiently in both CPU and RAM.
+It skips doing a lot of sanity checking with the assumption that a "front-end"
+HTTP/HTTPS server is placed between it and the Internet.
+
+WWW: http://search.cpan.org/dist/Feersum
diff --git a/www/p5-Feersum/pkg-plist b/www/p5-Feersum/pkg-plist
new file mode 100644
index 000000000000..458ba87cd5b3
--- /dev/null
+++ b/www/p5-Feersum/pkg-plist
@@ -0,0 +1,14 @@
+bin/feersum
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Feersum/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Feersum/Feersum.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Feersum/Feersum.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/Plack/Handler/Feersum.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Feersum.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Feersum/Runner.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Feersum/Connection.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Feersum/Connection/Handle.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Feersum
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Plack/Handler
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Plack
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Feersum/Connection
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Feersum