aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Gantry/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-09-28 07:02:47 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-09-28 07:02:47 +0000
commit49c0e39450bc4cc37b9846750165e51a6912b379 (patch)
tree2a685cf37123493a6500c7afdbf21d255dce8e7b /www/p5-Gantry/Makefile
parentc02cb48a1898beae1e17284fdf728178ff7ddd42 (diff)
downloadports-49c0e39450bc4cc37b9846750165e51a6912b379.tar.gz
ports-49c0e39450bc4cc37b9846750165e51a6912b379.zip
Notes
Diffstat (limited to 'www/p5-Gantry/Makefile')
-rw-r--r--www/p5-Gantry/Makefile98
1 files changed, 98 insertions, 0 deletions
diff --git a/www/p5-Gantry/Makefile b/www/p5-Gantry/Makefile
new file mode 100644
index 000000000000..49ec18ee17d5
--- /dev/null
+++ b/www/p5-Gantry/Makefile
@@ -0,0 +1,98 @@
+# New ports collection makefile for: p5-Gantry
+# Date created: 2006-09-26
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Gantry
+PORTVERSION= 3.40
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Gantry
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Web application framework for mod_perl, cgi, etc
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
+ ${SITE_PERL}/${PERL_ARCH}/Data/UUID.pm:${PORTSDIR}/devel/p5-Data-UUID \
+ ${SITE_PERL}/${PERL_ARCH}/Date/Calc.pm:${PORTSDIR}/devel/p5-Date-Calc \
+ ${SITE_PERL}/CGI/Simple.pm:${PORTSDIR}/www/p5-CGI-Simple \
+ ${SITE_PERL}/Data/FormValidator.pm:${PORTSDIR}/textproc/p5-Data-FormValidator \
+ ${SITE_PERL}/File/Copy/Recursive.pm:${PORTSDIR}/devel/p5-File-Copy-Recursive \
+ ${SITE_PERL}/HTTP/Server/Simple.pm:${PORTSDIR}/www/p5-HTTP-Server-Simple \
+ ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
+ p5-Template-Toolkit>=2.0:${PORTSDIR}/www/p5-Template-Toolkit
+
+PERL_MODBUILD= yes
+
+MAN3= Gantry.3 Gantry::Conf.3 Gantry::Conf::FAQ.3 \
+ Gantry::Conf::Provider.3 \
+ Gantry::Conf::Provider::FlatFile::Config::General.3 \
+ Gantry::Conf::Provider::FlatFile::Config::Tiny.3 \
+ Gantry::Conf::Provider::HTTP.3 \
+ Gantry::Conf::Provider::HTTP::Config::General.3 \
+ Gantry::Conf::Provider::ParamBuilder.3 \
+ Gantry::Conf::Provider::PerlSetVar.3 \
+ Gantry::Conf::Provider::SQL::PostgreSQL.3 \
+ Gantry::Conf::Tutorial.3 Gantry::Control.3 \
+ Gantry::Control::C::Access.3 \
+ Gantry::Control::C::AuthenBase.3 \
+ Gantry::Control::C::AuthenCDBI.3 \
+ Gantry::Control::C::AuthenRegular.3 \
+ Gantry::Control::C::Authz::PageBasedBase.3 \
+ Gantry::Control::C::Authz::PageBasedCDBI.3 \
+ Gantry::Control::C::Authz::PageBasedRegular.3 \
+ Gantry::Control::C::AuthzBase.3 \
+ Gantry::Control::C::AuthzCDBI.3 \
+ Gantry::Control::C::AuthzRegular.3 \
+ Gantry::Control::C::Groups.3 \
+ Gantry::Control::C::Pages.3 \
+ Gantry::Control::C::Users.3 \
+ Gantry::Control::Model::GEN::auth_group_members.3 \
+ Gantry::Control::Model::GEN::auth_groups.3 \
+ Gantry::Control::Model::GEN::auth_pages.3 \
+ Gantry::Control::Model::GEN::auth_users.3 \
+ Gantry::Control::Model::auth_group_members.3 \
+ Gantry::Control::Model::auth_group_members_cdbi.3 \
+ Gantry::Control::Model::auth_groups.3 \
+ Gantry::Control::Model::auth_groups_cdbi.3 \
+ Gantry::Control::Model::auth_pages.3 \
+ Gantry::Control::Model::auth_pages_cdbi.3 \
+ Gantry::Control::Model::auth_users.3 \
+ Gantry::Control::Model::auth_users_cdbi.3 \
+ Gantry::Docs::About.3 Gantry::Docs::DBConn.3 \
+ Gantry::Docs::FAQ.3 Gantry::Docs::QuickStart.3 \
+ Gantry::Docs::TOC.3 Gantry::Docs::Tutorial.3 \
+ Gantry::Docs::Why.3 Gantry::Engine::CGI.3 \
+ Gantry::Engine::MP13.3 Gantry::Engine::MP20.3 \
+ Gantry::Init.3 Gantry::Plugins::AutoCRUD.3 \
+ Gantry::Plugins::AutoCRUDHelper::CDBI.3 \
+ Gantry::Plugins::AutoCRUDHelper::DBIxClass.3 \
+ Gantry::Plugins::CRUD.3 Gantry::Plugins::Calendar.3 \
+ Gantry::Plugins::DBIxClassConn.3 Gantry::Plugins::Static.3 \
+ Gantry::Plugins::Validate.3 Gantry::Server.3 \
+ Gantry::Stash.3 Gantry::Stash::Controller.3 \
+ Gantry::Stash::View.3 Gantry::Stash::View::Form.3 \
+ Gantry::Template::Default.3 Gantry::Template::Framing.3 \
+ Gantry::Template::TT.3 Gantry::Utils::AuthCDBI.3 \
+ Gantry::Utils::CDBI.3 Gantry::Utils::CRUDHelp.3 \
+ Gantry::Utils::DB.3 Gantry::Utils::DBConnHelper.3 \
+ Gantry::Utils::DBConnHelper::MP13.3 \
+ Gantry::Utils::DBConnHelper::MP20.3 \
+ Gantry::Utils::DBConnHelper::Script.3 \
+ Gantry::Utils::DBIxClass.3 Gantry::Utils::HTML.3 \
+ Gantry::Utils::Model.3 Gantry::Utils::Model::Auth.3 \
+ Gantry::Utils::Model::Regular.3 \
+ Gantry::Utils::ModelHelper.3 Gantry::Utils::PODViewer.3 \
+ Gantry::Utils::PerlbalFixup.3 Gantry::Utils::SQL.3 \
+ Gantry::Utils::Validate.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires Perl 5.8.0 or newer. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>