aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Gantry
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-07-14 23:30:56 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-07-14 23:30:56 +0000
commit251388491eb899039115b40167f08bea95bceeda (patch)
tree8852d6e43540ecb777316fe513979d604b21bf50 /www/p5-Gantry
parent4378ea53ef7e23eb36addc4874e3c8409289e515 (diff)
downloadports-251388491eb899039115b40167f08bea95bceeda.tar.gz
ports-251388491eb899039115b40167f08bea95bceeda.zip
Notes
Diffstat (limited to 'www/p5-Gantry')
-rw-r--r--www/p5-Gantry/Makefile30
-rw-r--r--www/p5-Gantry/files/patch-Build.PL71
-rw-r--r--www/p5-Gantry/files/patch-lib__Gantry__Build.pm22
3 files changed, 96 insertions, 27 deletions
diff --git a/www/p5-Gantry/Makefile b/www/p5-Gantry/Makefile
index c9c415dac7e1..49c9371c68c1 100644
--- a/www/p5-Gantry/Makefile
+++ b/www/p5-Gantry/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Gantry
PORTVERSION= 3.54
+PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,6 +15,23 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Web application framework for mod_perl, cgi, etc
+BUILD_DEPENDS= ${SITE_PERL}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception \
+ ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
+ ${SITE_PERL}/${PERL_ARCH}/Data/UUID.pm:${PORTSDIR}/devel/p5-Data-UUID \
+ ${SITE_PERL}/${PERL_ARCH}/Date/Calc.pm:${PORTSDIR}/devel/p5-Date-Calc \
+ ${SITE_PERL}/CGI/Simple.pm:${PORTSDIR}/www/p5-CGI-Simple \
+ ${SITE_PERL}/Data/FormValidator.pm:${PORTSDIR}/textproc/p5-Data-FormValidator \
+ ${SITE_PERL}/File/Copy/Recursive.pm:${PORTSDIR}/devel/p5-File-Copy-Recursive \
+ ${SITE_PERL}/Hash/Merge.pm:${PORTSDIR}/textproc/p5-Hash-Merge \
+ ${SITE_PERL}/HTML/Prototype.pm:${PORTSDIR}/www/p5-HTML-Prototype \
+ ${SITE_PERL}/HTTP/Server/Simple.pm:${PORTSDIR}/www/p5-HTTP-Server-Simple \
+ ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
+ p5-Sub-Install>0:${PORTSDIR}/devel/p5-Sub-Install \
+ p5-Mail-RFC822-Address>0:${PORTSDIR}/mail/p5-Mail-RFC822-Address \
+ p5-Config-General>0:${PORTSDIR}/devel/p5-Config-General \
+ p5-JSON>0:${PORTSDIR}/converters/p5-JSON \
+ p5-Template-Toolkit>=2.0:${PORTSDIR}/www/p5-Template-Toolkit \
+ p5-Template-Plugin-HTML-SuperForm>0:${PORTSDIR}/textproc/p5-Template-Plugin-HTML-SuperForm
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
${SITE_PERL}/${PERL_ARCH}/Data/UUID.pm:${PORTSDIR}/devel/p5-Data-UUID \
${SITE_PERL}/${PERL_ARCH}/Date/Calc.pm:${PORTSDIR}/devel/p5-Date-Calc \
@@ -24,9 +42,12 @@ RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
${SITE_PERL}/HTML/Prototype.pm:${PORTSDIR}/www/p5-HTML-Prototype \
${SITE_PERL}/HTTP/Server/Simple.pm:${PORTSDIR}/www/p5-HTTP-Server-Simple \
${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
- p5-Template-Toolkit>=2.0:${PORTSDIR}/www/p5-Template-Toolkit
-BUILD_DEPENDS= ${RUN_DEPENDS}
-BUILD_DEPENDS+= ${SITE_PERL}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception
+ p5-Sub-Install>0:${PORTSDIR}/devel/p5-Sub-Install \
+ p5-Mail-RFC822-Address>0:${PORTSDIR}/mail/p5-Mail-RFC822-Address \
+ p5-Config-General>0:${PORTSDIR}/devel/p5-Config-General \
+ p5-JSON>0:${PORTSDIR}/converters/p5-JSON \
+ p5-Template-Toolkit>=2.0:${PORTSDIR}/www/p5-Template-Toolkit \
+ p5-Template-Plugin-HTML-SuperForm>0:${PORTSDIR}/textproc/p5-Template-Plugin-HTML-SuperForm
PERL_MODBUILD= 5.8.0+
@@ -117,6 +138,9 @@ MAN3= Gantry.3 \
Gantry::Utils::Threeway.3 \
Template::Plugin::GantryAuthCookie.3
+post-patch:
+ ${REINPLACE_CMD} -e 's,/home/httpd/html/gantry,${WWWDIR},g' -e 's,\$ENV{'GANTRY_TEMPLATE_PATH'},${WWWDIR},g' ${WRKSRC}/Build.PL
+
pre-configure:
@${MKDIR} ${WWWDIR}
diff --git a/www/p5-Gantry/files/patch-Build.PL b/www/p5-Gantry/files/patch-Build.PL
index 3eee7159a90b..f247d54b9424 100644
--- a/www/p5-Gantry/files/patch-Build.PL
+++ b/www/p5-Gantry/files/patch-Build.PL
@@ -1,26 +1,49 @@
---- Build.PL.orig 2007-06-20 03:11:06.000000000 +0800
-+++ Build.PL 2007-09-12 09:34:41.000000000 +0800
-@@ -36,10 +36,10 @@
- web_files => \@web_dirs,
- build_web_directory => 'root',
- install_web_directories => {
-- 'default' => '/home/httpd/html/gantry',
-- 'prod' => '/home/httpd/html/gantry',
-- 'dev' => '/home/httpd/html/gantry',
-- 'tim' => '/home/tkeefer/httpd/html/gantry'
-+ 'default' => '/usr/local/www/gantry',
-+ 'prod' => '/usr/local/www/gantry',
-+ 'dev' => '/usr/local/www/gantry',
-+ 'tim' => '/usr/local/www/gantry'
- },
- create_makefile_pl => 'passthrough',
- license => 'perl',
-@@ -105,7 +105,7 @@
- if ( not -d $template_path ) {
- my $make_path = $build->y_n(
- "$template_path does not exist, should I make it?",
+--- ./Build.PL.orig 2009-07-14 17:08:45.608765850 -0400
++++ ./Build.PL 2009-07-14 17:40:19.239457739 -0400
+@@ -106,27 +106,6 @@
+
+ $build->notes( install_web_directory => $template_path );
+
+-if ( not -d $template_path ) {
+- my $make_path = $ENV{'GANTRY_TEMPLATE_PATH'} || $build->y_n(
+- "$template_path does not exist, should I make it?",
- 'y'
-+ 'n'
- );
+- );
+-
+- if ( $make_path ) {
+- eval {
+- File::Path::mkpath( $template_path );
+- };
+- if ( $@ ) {
+- $@ =~ s/ at .+?$//;
+- print "Error: unable to create directory $template_path @_\n";
+- $build->notes( install_web_directory => '__skip__' );
+- }
+- }
+- else {
+- $build->notes( install_web_directory => '__skip__' );
+- }
+-}
+-
+ $build->create_build_script;
+
+ sub _custom_code {
+@@ -157,7 +136,6 @@
+
+ my $tmpl_dir = $self->notes( 'install_web_directory' );
+
+- if( $tmpl_dir && $tmpl_dir ne '__skip__' ) {
+
+ # write Init.pm file with install options
+
+@@ -235,10 +213,6 @@
+ else {
+ print "\n$num Gantry templates copied to $tmpl_dir\n";
+ }
+- }
+- else {
+- print "SKIPPING WEB CONTENT INSTALL\n";
+- }
+
+ print "\n";
- if ( $make_path ) {
diff --git a/www/p5-Gantry/files/patch-lib__Gantry__Build.pm b/www/p5-Gantry/files/patch-lib__Gantry__Build.pm
new file mode 100644
index 000000000000..cc0261f1c67d
--- /dev/null
+++ b/www/p5-Gantry/files/patch-lib__Gantry__Build.pm
@@ -0,0 +1,22 @@
+--- ./lib/Gantry/Build.pm.orig 2009-07-14 17:44:09.567989717 -0400
++++ ./lib/Gantry/Build.pm 2009-07-14 17:44:24.917686676 -0400
+@@ -115,8 +115,6 @@
+
+ my $tmpl_dir = $p->{web_dir};
+
+- if( $tmpl_dir && $tmpl_dir ne '__skip__' ) {
+-
+ if ( not -d $tmpl_dir and $p->{ create_web_dir } =~ /^n/i ) {
+ exit;
+ }
+@@ -145,10 +143,6 @@
+ else {
+ print "Web content copied: $num\n";
+ }
+- }
+- else {
+- print "SKIPPING WEB CONTENT INSTALL\n";
+- }
+ print "-" x 80;
+ print "\n";
+