aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Geo-Caching/Makefile
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-02-18 22:19:24 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-02-18 22:19:24 +0000
commit3322c6bfac9337681027ac5249a5d59ec8b25bec (patch)
tree9dd6542de494e8aa6c649fff0ca2c25e80ba5aef /www/p5-Geo-Caching/Makefile
parente1a4550e58321eb0cf343f72a117a08775795a15 (diff)
Adding port www/p5-Geo-Caching, an Object interface for querying Geocaching.com website.
Committed by: aaron Approved by: tobez (implicit)
Notes
Notes: svn path=/head/; revision=156338
Diffstat (limited to 'www/p5-Geo-Caching/Makefile')
-rw-r--r--www/p5-Geo-Caching/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/www/p5-Geo-Caching/Makefile b/www/p5-Geo-Caching/Makefile
new file mode 100644
index 000000000000..1c9fc11bb01d
--- /dev/null
+++ b/www/p5-Geo-Caching/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Geo-Caching
+# Date created: 18 Feb 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Geo-Caching
+PORTVERSION= 0.11
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Geo
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Object interface for querying Geocaching.com website
+
+BUILD_DEPENDS= ${SITE_PERL}/Geo/Cache.pm:${PORTSDIR}/misc/p5-Geo-Cache \
+ ${SITE_PERL}/WWW/Mechanize.pm:${PORTSDIR}/www/p5-WWW-Mechanize
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+
+MAN3= Geo::Caching.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires at least Perl5.8
+.endif
+
+.include <bsd.port.post.mk>