aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Google-Search
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2010-07-20 11:31:42 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2010-07-20 11:31:42 +0000
commit93bedc3013dc3ca84881d664951d26c8c556741e (patch)
tree9e5ec4c5ba9d51597d18333ab3cb5df805af25f7 /www/p5-Google-Search
parent1b9f75e361103afab94c27e06ca045b46b14d478 (diff)
Notes
Diffstat (limited to 'www/p5-Google-Search')
-rw-r--r--www/p5-Google-Search/Makefile29
-rw-r--r--www/p5-Google-Search/distinfo3
-rw-r--r--www/p5-Google-Search/pkg-descr4
-rw-r--r--www/p5-Google-Search/pkg-plist11
4 files changed, 47 insertions, 0 deletions
diff --git a/www/p5-Google-Search/Makefile b/www/p5-Google-Search/Makefile
new file mode 100644
index 000000000000..f47006bce05c
--- /dev/null
+++ b/www/p5-Google-Search/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-Google-Search
+# Date created: 20 Jul 2010
+# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Google-Search
+PORTVERSION= 0.027
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Interface to the Google AJAX Search API and suggestion API
+
+RUN_DEPENDS= p5-Any-Moose>=0:${PORTSDIR}/devel/p5-Any-Moose \
+ p5-JSON>=2.16:${PORTSDIR}/converters/p5-JSON \
+ p5-Carp-Clan-Share>=0:${PORTSDIR}/devel/p5-Carp-Clan-Share \
+ p5-Test-Most>=0:${PORTSDIR}/devel/p5-Test-Most \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-libwww>0:${PORTSDIR}/www/p5-libwww
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= 5.8.0+
+
+MAN3= Google::Search.3 Google::Search::Result.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Google-Search/distinfo b/www/p5-Google-Search/distinfo
new file mode 100644
index 000000000000..1907787fa2b1
--- /dev/null
+++ b/www/p5-Google-Search/distinfo
@@ -0,0 +1,3 @@
+MD5 (Google-Search-0.027.tar.gz) = 8c65436e4fdf552baa340645af6ec130
+SHA256 (Google-Search-0.027.tar.gz) = 5fee8ca4bc802736048472de603298db43dac33a43e1f76b67fd368ba344c845
+SIZE (Google-Search-0.027.tar.gz) = 11543
diff --git a/www/p5-Google-Search/pkg-descr b/www/p5-Google-Search/pkg-descr
new file mode 100644
index 000000000000..ade2f6a2c064
--- /dev/null
+++ b/www/p5-Google-Search/pkg-descr
@@ -0,0 +1,4 @@
+Google::Search is an interface to the Google AJAX Search API. Currently, their
+API looks like it will fetch you the top 64 results for your search query.
+
+WWW: http://search.cpan.org/dist/Google-Search/
diff --git a/www/p5-Google-Search/pkg-plist b/www/p5-Google-Search/pkg-plist
new file mode 100644
index 000000000000..35626b3b2842
--- /dev/null
+++ b/www/p5-Google-Search/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/Google/Search.pm
+%%SITE_PERL%%/Google/Search/Carp.pm
+%%SITE_PERL%%/Google/Search/Error.pm
+%%SITE_PERL%%/Google/Search/Page.pm
+%%SITE_PERL%%/Google/Search/Response.pm
+%%SITE_PERL%%/Google/Search/Result.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Google/Search/.packlist
+@dirrmtry %%SITE_PERL%%/Google/Search
+@dirrmtry %%SITE_PERL%%/Google
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Google/Search
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Google