aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTML-Element-Library
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-02-19 16:19:27 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-02-19 16:19:27 +0000
commit75b9dfaad424a3cb9290fc576328d9cc1e2975fb (patch)
tree108609593849f8e9461df33370adacda42b7b5c6 /www/p5-HTML-Element-Library
parentf38a428a20fea371f0f6f0a0cb19d2057bb19c42 (diff)
downloadports-75b9dfaad424a3cb9290fc576328d9cc1e2975fb.tar.gz
ports-75b9dfaad424a3cb9290fc576328d9cc1e2975fb.zip
Notes
Diffstat (limited to 'www/p5-HTML-Element-Library')
-rw-r--r--www/p5-HTML-Element-Library/Makefile37
-rw-r--r--www/p5-HTML-Element-Library/distinfo3
-rw-r--r--www/p5-HTML-Element-Library/pkg-descr5
-rw-r--r--www/p5-HTML-Element-Library/pkg-plist9
4 files changed, 54 insertions, 0 deletions
diff --git a/www/p5-HTML-Element-Library/Makefile b/www/p5-HTML-Element-Library/Makefile
new file mode 100644
index 000000000000..83dbe00f6937
--- /dev/null
+++ b/www/p5-HTML-Element-Library/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: p5-HTML-Element-Library
+# Date created: 2007/02/14
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-Element-Library
+PORTVERSION= 3.51
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= HTML::Element convenience functions
+
+BUILD_DEPENDS= p5-Array-Group>=0:${PORTSDIR}/devel/p5-Array-Group \
+ p5-File-Slurp>=0:${PORTSDIR}/devel/p5-File-Slurp \
+ p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils \
+ p5-List-Rotation-Cycle>=0:${PORTSDIR}/devel/p5-List-Rotation-Cycle \
+ p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate \
+ p5-Scalar-Listify>=0:${PORTSDIR}/devel/p5-Scalar-Listify \
+ p5-HTML-PrettyPrinter>=0:${PORTSDIR}/www/p5-HTML-PrettyPrinter \
+ p5-HTML-Tree>=0:${PORTSDIR}/www/p5-HTML-Tree
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= HTML::Element::Library.3 HTML::Element::Library::Changes.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+post-extract:
+ @${CP} ${WRKSRC}/Changes ${WRKSRC}/CHANGES
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-HTML-Element-Library/distinfo b/www/p5-HTML-Element-Library/distinfo
new file mode 100644
index 000000000000..bb2ac0c92d47
--- /dev/null
+++ b/www/p5-HTML-Element-Library/distinfo
@@ -0,0 +1,3 @@
+MD5 (HTML-Element-Library-3.51.tar.gz) = a3d1b131036014a0ebcc3dbcb32d6b61
+SHA256 (HTML-Element-Library-3.51.tar.gz) = c5c6291361fccf44298d4fbc94fa925f672d594dcddcd77319cbc768df881b57
+SIZE (HTML-Element-Library-3.51.tar.gz) = 32943
diff --git a/www/p5-HTML-Element-Library/pkg-descr b/www/p5-HTML-Element-Library/pkg-descr
new file mode 100644
index 000000000000..4aaa2812b07e
--- /dev/null
+++ b/www/p5-HTML-Element-Library/pkg-descr
@@ -0,0 +1,5 @@
+HTML::Element::Library - HTML::Element convenience functions
+This method provides API calls for common actions on trees when using
+HTML::Tree.
+
+WWW: http://search.cpan.org/dist/HTML-Element-Library/
diff --git a/www/p5-HTML-Element-Library/pkg-plist b/www/p5-HTML-Element-Library/pkg-plist
new file mode 100644
index 000000000000..c5d611f5b850
--- /dev/null
+++ b/www/p5-HTML-Element-Library/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Element/Library/.packlist
+%%SITE_PERL%%/HTML/Element/Library.pm
+%%SITE_PERL%%/HTML/Element/Library/Changes.pod
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Element/Library
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Element
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML
+@dirrmtry %%SITE_PERL%%/HTML/Element/Library
+@dirrmtry %%SITE_PERL%%/HTML/Element
+@dirrmtry %%SITE_PERL%%/HTML