aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTML-Form
diff options
context:
space:
mode:
authorFrederic Culot <culot@FreeBSD.org>2011-04-18 07:24:45 +0000
committerFrederic Culot <culot@FreeBSD.org>2011-04-18 07:24:45 +0000
commit6debb0146cf528fa09e47a543ce8e65c82220a4d (patch)
tree2a8074f7a8fcb145ddf4717c8ac36090fee826b7 /www/p5-HTML-Form
parent0fe16e817c68b7d3e96438c919160acbfe7f6163 (diff)
downloadports-6debb0146cf528fa09e47a543ce8e65c82220a4d.tar.gz
ports-6debb0146cf528fa09e47a543ce8e65c82220a4d.zip
Notes
Diffstat (limited to 'www/p5-HTML-Form')
-rw-r--r--www/p5-HTML-Form/Makefile26
-rw-r--r--www/p5-HTML-Form/distinfo2
-rw-r--r--www/p5-HTML-Form/pkg-descr5
-rw-r--r--www/p5-HTML-Form/pkg-plist5
4 files changed, 38 insertions, 0 deletions
diff --git a/www/p5-HTML-Form/Makefile b/www/p5-HTML-Form/Makefile
new file mode 100644
index 000000000000..3f53035db7c2
--- /dev/null
+++ b/www/p5-HTML-Form/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-HTML-Form
+# Date created: 2011-04-18
+# Whom: Frederic Culot <culot@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-Form
+PORTVERSION= 6.00
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Class that represents an HTML form element
+
+RUN_DEPENDS= p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
+ p5-HTTP-Message>=6:${PORTSDIR}/www/p5-HTTP-Message \
+ p5-URI>=1.10:${PORTSDIR}/net/p5-URI
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= HTML::Form.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTML-Form/distinfo b/www/p5-HTML-Form/distinfo
new file mode 100644
index 000000000000..b11d4f1801c7
--- /dev/null
+++ b/www/p5-HTML-Form/distinfo
@@ -0,0 +1,2 @@
+SHA256 (HTML-Form-6.00.tar.gz) = b41b6f5480493d427a56974c0fb6f51e807d93938ef1518dd22454b93cad4987
+SIZE (HTML-Form-6.00.tar.gz) = 23074
diff --git a/www/p5-HTML-Form/pkg-descr b/www/p5-HTML-Form/pkg-descr
new file mode 100644
index 000000000000..6fdd7f6bbaf5
--- /dev/null
+++ b/www/p5-HTML-Form/pkg-descr
@@ -0,0 +1,5 @@
+Objects of the HTML::Form class represent a single HTML <form> ... </form>
+instance. A form consists of a sequence of inputs that usually have names,
+and which can take on various values.
+
+WWW: http://search.cpan.org/dist/HTML-Form/
diff --git a/www/p5-HTML-Form/pkg-plist b/www/p5-HTML-Form/pkg-plist
new file mode 100644
index 000000000000..e9b91b8ebef1
--- /dev/null
+++ b/www/p5-HTML-Form/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/HTML/Form.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Form/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Form
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML
+@dirrmtry %%SITE_PERL%%/HTML