aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTML-FormFu/Makefile
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2008-07-23 10:54:40 +0000
committerAndrej Zverev <az@FreeBSD.org>2008-07-23 10:54:40 +0000
commit778319e394b8fba8c9fc4dc922a597bfdcb33bd3 (patch)
tree88aa57136a468b4d77bbab3e8b638751bdb444fd /www/p5-HTML-FormFu/Makefile
parent43d7f04cac5c06214ba74eb265affd82bb6454df (diff)
Notes
Diffstat (limited to 'www/p5-HTML-FormFu/Makefile')
-rw-r--r--www/p5-HTML-FormFu/Makefile21
1 files changed, 16 insertions, 5 deletions
diff --git a/www/p5-HTML-FormFu/Makefile b/www/p5-HTML-FormFu/Makefile
index e9a2c0db657f..d2f94ac67cdc 100644
--- a/www/p5-HTML-FormFu/Makefile
+++ b/www/p5-HTML-FormFu/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= HTML-FormFu
-PORTVERSION= 0.02004
+PORTVERSION= 0.03001
CATEGORIES= www perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= ../by-authors/id/C/CF/CFRANKS
@@ -18,13 +18,17 @@ COMMENT= HTML Form Creation, Rendering and Validation Framework
BUILD_DEPENDS= p5-Class-Accessor-Chained>=0:${PORTSDIR}/devel/p5-Class-Accessor-Chained \
p5-Class-C3>=0.19:${PORTSDIR}/devel/p5-Class-C3 \
p5-Config-Any>=0.10:${PORTSDIR}/devel/p5-Config-Any \
+ p5-Crypt-CBC>=0:${PORTSDIR}/security/p5-Crypt-CBC \
+ p5-Crypt-DES>=0:${PORTSDIR}/security/p5-Crypt-DES \
p5-Data-Visitor>=0.02:${PORTSDIR}/devel/p5-Data-Visitor \
p5-Date-Calc>=0:${PORTSDIR}/devel/p5-Date-Calc \
+ p5-DateTime>=0.38:${PORTSDIR}/devel/p5-DateTime \
p5-DateTime-Format-Builder>=0.79.01:${PORTSDIR}/devel/p5-DateTime-Format-Builder \
p5-DateTime-Format-Strptime>=0:${PORTSDIR}/devel/p5-DateTime-Format-Strptime \
p5-DateTime-Locale>=0:${PORTSDIR}/devel/p5-DateTime-Locale \
p5-Email-Valid>=0:${PORTSDIR}/mail/p5-Email-Valid \
p5-File-ShareDir>=0.04:${PORTSDIR}/devel/p5-File-ShareDir \
+ p5-DateTime-Format-Natural>0:${PORTSDIR}/devel/p5-DateTime-Format-Natural \
p5-HTML-Scrubber>=0:${PORTSDIR}/www/p5-HTML-Scrubber \
p5-HTML-TokeParser-Simple>=3.14:${PORTSDIR}/www/p5-HTML-TokeParser-Simple \
p5-List-MoreUtils>=0.16:${PORTSDIR}/lang/p5-List-MoreUtils \
@@ -35,8 +39,7 @@ BUILD_DEPENDS= p5-Class-Accessor-Chained>=0:${PORTSDIR}/devel/p5-Class-Accessor-
p5-Task-Weaken>=0:${PORTSDIR}/devel/p5-Task-Weaken \
p5-Template-Toolkit>=0:${PORTSDIR}/www/p5-Template-Toolkit \
p5-Test-NoWarnings>=0.083:${PORTSDIR}/devel/p5-Test-NoWarnings \
- p5-YAML-Syck>=0:${PORTSDIR}/textproc/p5-YAML-Syck \
- p5-ExtUtils-MakeMaker>=6.11:${PORTSDIR}/devel/p5-ExtUtils-MakeMaker
+ p5-YAML-Syck>=0:${PORTSDIR}/textproc/p5-YAML-Syck
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= 5.8.1+
@@ -112,7 +115,6 @@ MAN3= HTML::FormFu::Inflator.3 \
HTML::FormFu::Element::Checkbox.3 \
HTML::FormFu::Element::Repeatable.3 \
HTML::FormFu::Element::Src.3 \
- HTML::FormFu::Model::DBIC.3 \
HTML::FormFu::Element::Fieldset.3 \
HTML::FormFu::Constraint::Printable.3 \
HTML::FormFu::Element::Text.3 \
@@ -130,6 +132,15 @@ MAN3= HTML::FormFu::Inflator.3 \
HTML::FormFu::Element::ContentButton.3 \
HTML::FormFu::Filter::Regex.3 \
HTML::FormFu::Filter::HTMLScrubber.3 \
- HTML::FormFu::Constraint::Set.3
+ HTML::FormFu::Constraint::Set.3 \
+ HTML::FormFu::UploadParam.3 \
+ HTML::FormFu::Inflator::CompoundDateTime.3 \
+ HTML::FormFu::Deflator::CompoundDateTime.3 \
+ HTML::FormFu::Filter::Split.3 \
+ HTML::FormFu::Filter::CompoundJoin.3 \
+ HTML::FormFu::Plugin::StashValid.3 \
+ HTML::FormFu::Deflator::CompoundSplit.3 \
+ HTML::FormFu::Plugin.3 \
+ HTML::FormFu::Model.3
.include <bsd.port.mk>