aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTML-Mason
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-10-12 15:16:44 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-10-12 15:16:44 +0000
commit2ca2cdd0c5f979a28384571fef9fa17dcf02c88e (patch)
tree7fbd367dbd37d8e30887bad893e487d517c5e0fc /www/p5-HTML-Mason
parentde525335f317c5df9bca6ff863b96393aee23598 (diff)
downloadports-2ca2cdd0c5f979a28384571fef9fa17dcf02c88e.tar.gz
ports-2ca2cdd0c5f979a28384571fef9fa17dcf02c88e.zip
Notes
Diffstat (limited to 'www/p5-HTML-Mason')
-rw-r--r--www/p5-HTML-Mason/Makefile51
-rw-r--r--www/p5-HTML-Mason/distinfo4
-rw-r--r--www/p5-HTML-Mason/pkg-descr36
-rw-r--r--www/p5-HTML-Mason/pkg-plist42
4 files changed, 63 insertions, 70 deletions
diff --git a/www/p5-HTML-Mason/Makefile b/www/p5-HTML-Mason/Makefile
index 6989810a42c8..694a25b9ef5f 100644
--- a/www/p5-HTML-Mason/Makefile
+++ b/www/p5-HTML-Mason/Makefile
@@ -1,12 +1,12 @@
# $FreeBSD$
PORTNAME= HTML-Mason
-PORTVERSION= 1.50
+PORTVERSION= 1.52
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= perl@FreeBSD.org
COMMENT= High-performance, dynamic web site authoring system
LICENSE= ART10 GPLv1
@@ -23,54 +23,19 @@ TEST_DEPENDS= p5-CHI>=0.210:${PORTSDIR}/devel/p5-CHI \
p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep \
p5-Test-Memory-Cycle>=0:${PORTSDIR}/devel/p5-Test-Memory-Cycle
+OPTIONS_DEFINE= MODPERL
+
USES= perl5
USE_PERL5= configure
-MAN3= HTML::Mason.3 \
- HTML::Mason::Admin.3 \
- HTML::Mason::ApacheHandler.3 \
- HTML::Mason::CGIHandler.3 \
- HTML::Mason::Cache::BaseCache.3 \
- HTML::Mason::Compiler.3 \
- HTML::Mason::Compiler::ToObject.3 \
- HTML::Mason::Component.3 \
- HTML::Mason::Component::FileBased.3 \
- HTML::Mason::Component::Subcomponent.3 \
- HTML::Mason::ComponentSource.3 \
- HTML::Mason::Devel.3 \
- HTML::Mason::Escapes.3 \
- HTML::Mason::Exceptions.3 \
- HTML::Mason::FakeApache.3 \
- HTML::Mason::Interp.3 \
- HTML::Mason::Lexer.3 \
- HTML::Mason::MethodMaker.3 \
- HTML::Mason::Params.3 \
- HTML::Mason::Parser.3 \
- HTML::Mason::Plugin.3 \
- HTML::Mason::Plugin::Context.3 \
- HTML::Mason::Request.3 \
- HTML::Mason::Resolver.3 \
- HTML::Mason::Resolver::File.3 \
- HTML::Mason::Resolver::Null.3 \
- HTML::Mason::Subclassing.3 \
- HTML::Mason::Tests.3 \
- HTML::Mason::Tools.3 \
- HTML::Mason::Utils.3
-
-OPTIONS_DEFINE= MODPERL
+MODPERL_BUILD_DEPENDS= p5-libapreq2>=0:${PORTSDIR}/www/p5-libapreq2
+MODPERL_RUN_DEPENDS= p5-libapreq2>=0:${PORTSDIR}/www/p5-libapreq2
+MODPERL_USE= APACHE_RUN=yes
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e '/bin\/convert/d' ${WRKSRC}/Makefile.PL
post-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/blib/script/mason.pl ${PREFIX}/bin/
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MMODPERL}
-RUN_DEPENDS+= p5-libapreq2>=0:${PORTSDIR}/www/p5-libapreq2
-USE_APACHE_RUN= 22+
-.endif
+ ${INSTALL_SCRIPT} ${WRKSRC}/blib/script/mason.pl ${STAGEDIR}${PREFIX}/bin/
.include <bsd.port.mk>
diff --git a/www/p5-HTML-Mason/distinfo b/www/p5-HTML-Mason/distinfo
index e536771d9f63..f28f10911916 100644
--- a/www/p5-HTML-Mason/distinfo
+++ b/www/p5-HTML-Mason/distinfo
@@ -1,2 +1,2 @@
-SHA256 (HTML-Mason-1.50.tar.gz) = 0becd8d11090647704239e230c533d5d31a2c2b99dca916000e66a4a7d7135b1
-SIZE (HTML-Mason-1.50.tar.gz) = 280619
+SHA256 (HTML-Mason-1.52.tar.gz) = 0934f8405f03aec4a69152113035c7ef455994b08e889935f171ec598eb36e7c
+SIZE (HTML-Mason-1.52.tar.gz) = 311110
diff --git a/www/p5-HTML-Mason/pkg-descr b/www/p5-HTML-Mason/pkg-descr
index 905aad407c20..9fa7c797edc0 100644
--- a/www/p5-HTML-Mason/pkg-descr
+++ b/www/p5-HTML-Mason/pkg-descr
@@ -1,23 +1,21 @@
-Mason is a tool for building, serving and managing large web
-sites. Its features make it an ideal backend for high load sites
-serving dynamic content, such as online newspapers or database driven
-e-commerce sites.
+Mason is a tool for building, serving and managing large web sites. Its features
+make it an ideal backend for high load sites serving dynamic content, such as
+online newspapers or database driven e-commerce sites.
-Mason's various pieces revolve around the notion of "components''. A
-component is a mix of HTML, Perl, and special Mason commands, one
-component per file. So-called "top-level" components represent entire
-web-pages, while smaller components typically return HTML snippets for
-embedding in top-level components. This object-like architecture
-greatly simplifies site maintenance: change a shared component, and
-you instantly changed all dependant pages that refer to it across a
-site (or across many virtual sites).
+Mason's various pieces revolve around the notion of "components". A component is
+a mix of HTML, Perl, and special Mason commands, one component per file.
+So-called "top-level" components represent entire web-pages, while smaller
+components typically return HTML snippets for embedding in top-level components.
+This object-like architecture greatly simplifies site maintenance: change a
+shared component, and you instantly changed all dependant pages that refer to it
+across a site (or across many virtual sites).
-Mason's component syntax lets designers separate a web page into
-programmatic and design elements. This means the esoteric Perl bits
-can be hidden near the bottom of a component, preloading simple
-variables for use above in the HTML. In our own experience, this frees
-content managers (i.e., non-programmers) to work on the layout without
-getting mired in programming details. Techies, however, still enjoy
-the full power of Perl.
+Mason's component syntax lets designers separate a web page into programmatic
+and design elements. This means the esoteric Perl bits can be hidden near the
+bottom of a component, preloading simple variables for use above in the HTML. In
+our own experience, this frees content managers (i.e., non-programmers) to work
+on the layout without getting mired in programming details. Techies, however,
+still enjoy the full power of Perl.
+WWW: http://search.cpan.org/dist/HTML-Mason/
WWW: http://www.masonhq.com/
diff --git a/www/p5-HTML-Mason/pkg-plist b/www/p5-HTML-Mason/pkg-plist
index 507a8ed8fb33..2b3d3b41b454 100644
--- a/www/p5-HTML-Mason/pkg-plist
+++ b/www/p5-HTML-Mason/pkg-plist
@@ -1,8 +1,8 @@
bin/mason.pl
%%SITE_PERL%%/HTML/Mason.pm
%%SITE_PERL%%/HTML/Mason/Admin.pod
-%%SITE_PERL%%/HTML/Mason/ApacheHandler.pm
%%SITE_PERL%%/HTML/Mason/Apache/Request.pm
+%%SITE_PERL%%/HTML/Mason/ApacheHandler.pm
%%SITE_PERL%%/HTML/Mason/CGIHandler.pm
%%SITE_PERL%%/HTML/Mason/Cache/BaseCache.pm
%%SITE_PERL%%/HTML/Mason/Compiler.pm
@@ -32,13 +32,43 @@ bin/mason.pl
%%SITE_PERL%%/HTML/Mason/Tools.pm
%%SITE_PERL%%/HTML/Mason/Utils.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Mason/.packlist
+%%PERL5_MAN3%%/HTML::Mason.3.gz
+%%PERL5_MAN3%%/HTML::Mason::Admin.3.gz
+%%PERL5_MAN3%%/HTML::Mason::ApacheHandler.3.gz
+%%PERL5_MAN3%%/HTML::Mason::CGIHandler.3.gz
+%%PERL5_MAN3%%/HTML::Mason::Cache::BaseCache.3.gz
+%%PERL5_MAN3%%/HTML::Mason::Compiler.3.gz
+%%PERL5_MAN3%%/HTML::Mason::Compiler::ToObject.3.gz
+%%PERL5_MAN3%%/HTML::Mason::Component.3.gz
+%%PERL5_MAN3%%/HTML::Mason::Component::FileBased.3.gz
+%%PERL5_MAN3%%/HTML::Mason::Component::Subcomponent.3.gz
+%%PERL5_MAN3%%/HTML::Mason::ComponentSource.3.gz
+%%PERL5_MAN3%%/HTML::Mason::Devel.3.gz
+%%PERL5_MAN3%%/HTML::Mason::Escapes.3.gz
+%%PERL5_MAN3%%/HTML::Mason::Exceptions.3.gz
+%%PERL5_MAN3%%/HTML::Mason::FakeApache.3.gz
+%%PERL5_MAN3%%/HTML::Mason::Interp.3.gz
+%%PERL5_MAN3%%/HTML::Mason::Lexer.3.gz
+%%PERL5_MAN3%%/HTML::Mason::MethodMaker.3.gz
+%%PERL5_MAN3%%/HTML::Mason::Params.3.gz
+%%PERL5_MAN3%%/HTML::Mason::Parser.3.gz
+%%PERL5_MAN3%%/HTML::Mason::Plugin.3.gz
+%%PERL5_MAN3%%/HTML::Mason::Plugin::Context.3.gz
+%%PERL5_MAN3%%/HTML::Mason::Request.3.gz
+%%PERL5_MAN3%%/HTML::Mason::Resolver.3.gz
+%%PERL5_MAN3%%/HTML::Mason::Resolver::File.3.gz
+%%PERL5_MAN3%%/HTML::Mason::Resolver::Null.3.gz
+%%PERL5_MAN3%%/HTML::Mason::Subclassing.3.gz
+%%PERL5_MAN3%%/HTML::Mason::Tests.3.gz
+%%PERL5_MAN3%%/HTML::Mason::Tools.3.gz
+%%PERL5_MAN3%%/HTML::Mason::Utils.3.gz
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Mason
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML
-@dirrm %%SITE_PERL%%/HTML/Mason/Apache
-@dirrm %%SITE_PERL%%/HTML/Mason/Cache
-@dirrm %%SITE_PERL%%/HTML/Mason/Compiler
-@dirrm %%SITE_PERL%%/HTML/Mason/Component
-@dirrm %%SITE_PERL%%/HTML/Mason/Plugin
@dirrm %%SITE_PERL%%/HTML/Mason/Resolver
+@dirrm %%SITE_PERL%%/HTML/Mason/Plugin
+@dirrm %%SITE_PERL%%/HTML/Mason/Component
+@dirrm %%SITE_PERL%%/HTML/Mason/Compiler
+@dirrm %%SITE_PERL%%/HTML/Mason/Cache
+@dirrm %%SITE_PERL%%/HTML/Mason/Apache
@dirrm %%SITE_PERL%%/HTML/Mason
@dirrmtry %%SITE_PERL%%/HTML