aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTML-Parser
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2000-10-13 02:38:44 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2000-10-13 02:38:44 +0000
commitb05df5b5cecc9e2339932abaa67e41eb1a804517 (patch)
tree68a2a1ec80d2b343511864ed0016647e5ca22132 /www/p5-HTML-Parser
parent7d342f50d48dea92dcfdfcd26ada9f3668d09378 (diff)
downloadports-b05df5b5cecc9e2339932abaa67e41eb1a804517.tar.gz
ports-b05df5b5cecc9e2339932abaa67e41eb1a804517.zip
Notes
Diffstat (limited to 'www/p5-HTML-Parser')
-rw-r--r--www/p5-HTML-Parser/Makefile4
-rw-r--r--www/p5-HTML-Parser/distinfo2
-rw-r--r--www/p5-HTML-Parser/files/patch-Makefile.PL23
3 files changed, 27 insertions, 2 deletions
diff --git a/www/p5-HTML-Parser/Makefile b/www/p5-HTML-Parser/Makefile
index 2b7a9b1250f2..1c3c7518641e 100644
--- a/www/p5-HTML-Parser/Makefile
+++ b/www/p5-HTML-Parser/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= HTML-Parser
-PORTVERSION= 3.10
+PORTVERSION= 3.13
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= HTML
@@ -14,6 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= dima@Chg.RU
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/HTML/Tagset.pm:${PORTSDIR}/www/p5-HTML-Tagset
+
USE_PERL5= yes
MAN3= HTML::Entities.3 \
diff --git a/www/p5-HTML-Parser/distinfo b/www/p5-HTML-Parser/distinfo
index 8c3027d13520..8d8b60ab047c 100644
--- a/www/p5-HTML-Parser/distinfo
+++ b/www/p5-HTML-Parser/distinfo
@@ -1 +1 @@
-MD5 (HTML-Parser-3.10.tar.gz) = a8d95c347d8c7eb6de0a633ff220545e
+MD5 (HTML-Parser-3.13.tar.gz) = 75a61c3207923774d028bebbadee35aa
diff --git a/www/p5-HTML-Parser/files/patch-Makefile.PL b/www/p5-HTML-Parser/files/patch-Makefile.PL
new file mode 100644
index 000000000000..c9ebc2def493
--- /dev/null
+++ b/www/p5-HTML-Parser/files/patch-Makefile.PL
@@ -0,0 +1,23 @@
+--- Makefile.PL.orig Fri Oct 13 08:53:50 2000
++++ Makefile.PL Fri Oct 13 09:29:25 2000
+@@ -10,19 +10,7 @@
+ }
+
+ if ($] >= 5.006) {
+- print <<"EOT";
+-
+-Perl-5.6 provide experimental core support for Unicode strings. You
+-can compile HTML::Entities so that Unicode entities like &euro; and
+-&#x20AC; are decoded into a string containing "\\x{20AC}". If you
+-select no to the question below such entities will be left alone and
+-only entities in the Latin-1 range is decoded.
+-
+-EOT
+- my $ans = prompt("Do you want decoding on unicode entities?", "no");
+- if ($ans =~ /^y(es)?$/i) {
+- push(@define, "-DUNICODE_ENTITIES");
+- }
++ push(@define, "-DUNICODE_ENTITIES");
+ }
+ push(@extra, "DEFINE" => "@define") if @define;
+