aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTML-RSSAutodiscovery/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-09-26 01:49:17 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-09-26 01:49:17 +0000
commit5272849d256e398dc529e32a160e17cb070d7adf (patch)
treeb4897bf48811e19d694e256dd170a828f7047c1c /www/p5-HTML-RSSAutodiscovery/Makefile
parent98e12f723a6025c6e7c141a26b02f11873f2cb1b (diff)
downloadports-5272849d256e398dc529e32a160e17cb070d7adf.tar.gz
ports-5272849d256e398dc529e32a160e17cb070d7adf.zip
Notes
Diffstat (limited to 'www/p5-HTML-RSSAutodiscovery/Makefile')
-rw-r--r--www/p5-HTML-RSSAutodiscovery/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/www/p5-HTML-RSSAutodiscovery/Makefile b/www/p5-HTML-RSSAutodiscovery/Makefile
new file mode 100644
index 000000000000..befc8f36cdf2
--- /dev/null
+++ b/www/p5-HTML-RSSAutodiscovery/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-HTML-RSSAutodiscovery
+# Date created: 2006-09-25
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-RSSAutodiscovery
+PORTVERSION= 1.21
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Methods for retreiving RSS-ish information from an HTML document
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600 # Inherited from both dependencies
+IGNORE= requires Perl 5.6.0 or newer. Install lang/perl5.8 and try again
+.endif
+
+MAN3= HTML::RSSAutodiscovery.3
+
+.include <bsd.port.post.mk>