aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTML-StripScripts
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2008-05-09 17:25:59 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2008-05-09 17:25:59 +0000
commit5b6b69da49ad3172a74b9afcb0d48858d12d9904 (patch)
tree4272dce5c2d95730629f706c4076c6e0c90d47c1 /www/p5-HTML-StripScripts
parent430838889b08d39c15f52756f11acd02cfbb26dc (diff)
downloadports-5b6b69da49ad3172a74b9afcb0d48858d12d9904.tar.gz
ports-5b6b69da49ad3172a74b9afcb0d48858d12d9904.zip
Notes
Diffstat (limited to 'www/p5-HTML-StripScripts')
-rw-r--r--www/p5-HTML-StripScripts/Makefile21
-rw-r--r--www/p5-HTML-StripScripts/distinfo3
-rw-r--r--www/p5-HTML-StripScripts/pkg-descr23
-rw-r--r--www/p5-HTML-StripScripts/pkg-plist5
4 files changed, 52 insertions, 0 deletions
diff --git a/www/p5-HTML-StripScripts/Makefile b/www/p5-HTML-StripScripts/Makefile
new file mode 100644
index 000000000000..0515c7409ede
--- /dev/null
+++ b/www/p5-HTML-StripScripts/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: p5-HTML-StripScripts
+# Date Created: May 08, 2008
+# Whom: kftseng@iyard.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-StripScripts
+PORTVERSION= 1.04
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kftseng@iyard.org
+COMMENT= Strip scripting constructs out of HTML
+
+PERL_CONFIGURE= yes
+
+MAN3= HTML::StripScripts.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTML-StripScripts/distinfo b/www/p5-HTML-StripScripts/distinfo
new file mode 100644
index 000000000000..a972cd0690be
--- /dev/null
+++ b/www/p5-HTML-StripScripts/distinfo
@@ -0,0 +1,3 @@
+MD5 (HTML-StripScripts-1.04.tar.gz) = aecd01e273bddbf60dca2a923163826d
+SHA256 (HTML-StripScripts-1.04.tar.gz) = 6d6cd9c2eaefb14ed80f5ef60a746979887783bed05ee92d3be9ec0a5cf8c33d
+SIZE (HTML-StripScripts-1.04.tar.gz) = 43708
diff --git a/www/p5-HTML-StripScripts/pkg-descr b/www/p5-HTML-StripScripts/pkg-descr
new file mode 100644
index 000000000000..abac624f6fb7
--- /dev/null
+++ b/www/p5-HTML-StripScripts/pkg-descr
@@ -0,0 +1,23 @@
+This module strips scripting constructs out of HTML, leaving as
+much non-scripting markup in place as possible. This allows web
+applications to display HTML originating from an untrusted source
+without introducing XSS (cross site scripting) vulnerabilities.
+You will probably use HTML::StripScripts::Parser rather than using
+this module directly.
+
+The process is based on whitelists of tags, attributes and attribute
+values. This approach is the most secure against disguised scripting
+constructs hidden in malicious HTML documents. As well as removing
+scripting constructs, this module ensures that there is a matching
+end for each start tag, and that the tags are properly nested.
+
+Previously, in order to customise the output, you needed to subclass
+HTML::StripScripts and override methods. Now, most customisation
+can be done through the Rules option provided to new(). (See
+examples/declaration/ and examples/tags/ for cases where subclassing
+is necessary.) The HTML document must be parsed into start tags,
+end tags and text before it can be filtered by this module. Use
+either HTML::StripScripts::Parser or HTML::StripScripts::Regex
+instead if you want to input an unparsed HTML document.
+
+WWW: http://search.cpan.org/dist/HTML-StripScripts/
diff --git a/www/p5-HTML-StripScripts/pkg-plist b/www/p5-HTML-StripScripts/pkg-plist
new file mode 100644
index 000000000000..ea598ce304cd
--- /dev/null
+++ b/www/p5-HTML-StripScripts/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/HTML/StripScripts.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/StripScripts/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/StripScripts
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML
+@dirrmtry %%SITE_PERL%%/HTML