aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTML-Template-Compiled
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-09-16 19:16:29 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-09-16 19:16:29 +0000
commit9142df48acbeafe7cd07cdb24737ee535e4fa479 (patch)
treecf940ea7e1715430ca69fc0cdefe81154a90e949 /www/p5-HTML-Template-Compiled
parent0f884fd1f5c0612e0a2339111ee4759f6436282a (diff)
downloadports-9142df48acbeafe7cd07cdb24737ee535e4fa479.tar.gz
ports-9142df48acbeafe7cd07cdb24737ee535e4fa479.zip
Notes
Diffstat (limited to 'www/p5-HTML-Template-Compiled')
-rw-r--r--www/p5-HTML-Template-Compiled/Makefile40
-rw-r--r--www/p5-HTML-Template-Compiled/distinfo2
-rw-r--r--www/p5-HTML-Template-Compiled/pkg-descr4
-rw-r--r--www/p5-HTML-Template-Compiled/pkg-plist12
4 files changed, 58 insertions, 0 deletions
diff --git a/www/p5-HTML-Template-Compiled/Makefile b/www/p5-HTML-Template-Compiled/Makefile
new file mode 100644
index 000000000000..61833c231a6a
--- /dev/null
+++ b/www/p5-HTML-Template-Compiled/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: p5-HTML-Template-Compiled
+# Date Created: 09 Sep 2005
+# Whom: Zach Thompson <hideo@lastamericanempire.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-Template-Compiled
+PORTVERSION= 0.43
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hideo@lastamericanempire.com
+COMMENT= Templating system that HTML::Template files to Perl code
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/${PERL_ARCH}/HTML/Entities.pm:${PORTSDIR}/www/p5-HTML-Parser \
+ ${SITE_PERL}/Data/TreeDumper.pm:${PORTSDIR}/devel/p5-Data-TreeDumper \
+ ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= HTML::Template::Compiled.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+post-patch:
+ @${PERL} -pi -e 's/^our\s+(.VERSION.+)$$/$$1/o;' \
+ -e '$$_ = "" if /(no|use) warnings/;' \
+ ${WRKSRC}/lib/HTML/Template/Compiled.pm \
+ ${WRKSRC}/lib/HTML/Template/Compiled/Utils.pm \
+ ${WRKSRC}/lib/HTML/Template/Compiled/Plugin/DHTML.pm
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-HTML-Template-Compiled/distinfo b/www/p5-HTML-Template-Compiled/distinfo
new file mode 100644
index 000000000000..9f7ada05cf64
--- /dev/null
+++ b/www/p5-HTML-Template-Compiled/distinfo
@@ -0,0 +1,2 @@
+MD5 (HTML-Template-Compiled-0.43.tar.gz) = 6225f01671a48abe5ce46e25d2fd1d56
+SIZE (HTML-Template-Compiled-0.43.tar.gz) = 17157
diff --git a/www/p5-HTML-Template-Compiled/pkg-descr b/www/p5-HTML-Template-Compiled/pkg-descr
new file mode 100644
index 000000000000..91d80cab9f32
--- /dev/null
+++ b/www/p5-HTML-Template-Compiled/pkg-descr
@@ -0,0 +1,4 @@
+Fast templating system using the same syntax as HTML::Template
+but which compiles templates to perl code.
+
+WWW: http://www.tinita.de/projects/perl/
diff --git a/www/p5-HTML-Template-Compiled/pkg-plist b/www/p5-HTML-Template-Compiled/pkg-plist
new file mode 100644
index 000000000000..0e2ad666c4d2
--- /dev/null
+++ b/www/p5-HTML-Template-Compiled/pkg-plist
@@ -0,0 +1,12 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/HTML/Template/Compiled.pm
+%%SITE_PERL%%/HTML/Template/Compiled/Plugin/DHTML.pm
+%%SITE_PERL%%/HTML/Template/Compiled/Utils.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Template/Compiled/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Template/Compiled
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Template 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML 2>/dev/null || true
+@dirrm %%SITE_PERL%%/HTML/Template/Compiled/Plugin
+@dirrm %%SITE_PERL%%/HTML/Template/Compiled
+@unexec rmdir %D/%%SITE_PERL%%/HTML/Template 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/HTML 2>/dev/null || true