aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTML-Template
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2000-10-27 01:54:27 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2000-10-27 01:54:27 +0000
commit00ee3007f2ccf4943b1c0b7ebb781460020282e9 (patch)
tree4afdd027f8ce5a4a8ce3ed81069aeefe4120e4ce /www/p5-HTML-Template
parent5f1932174aa0aa32faef82cbf3f42693a8473c46 (diff)
downloadports-00ee3007f2ccf4943b1c0b7ebb781460020282e9.tar.gz
ports-00ee3007f2ccf4943b1c0b7ebb781460020282e9.zip
Notes
Diffstat (limited to 'www/p5-HTML-Template')
-rw-r--r--www/p5-HTML-Template/Makefile27
-rw-r--r--www/p5-HTML-Template/distinfo1
-rw-r--r--www/p5-HTML-Template/pkg-comment1
-rw-r--r--www/p5-HTML-Template/pkg-descr3
-rw-r--r--www/p5-HTML-Template/pkg-plist5
5 files changed, 37 insertions, 0 deletions
diff --git a/www/p5-HTML-Template/Makefile b/www/p5-HTML-Template/Makefile
new file mode 100644
index 000000000000..b51f25382e0f
--- /dev/null
+++ b/www/p5-HTML-Template/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-HTML-Template
+# Date Created: 26 Oct, 2000
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-Template
+PORTVERSION= 2.0
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+
+USE_PERL5= yes
+
+MAN3= HTML::Template.3
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+do-configure:
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
+ CC="${CC}" CCFLAGS="${CFLAGS}"
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTML-Template/distinfo b/www/p5-HTML-Template/distinfo
new file mode 100644
index 000000000000..03b26fdf8a96
--- /dev/null
+++ b/www/p5-HTML-Template/distinfo
@@ -0,0 +1 @@
+MD5 (HTML-Template-2.0.tar.gz) = abfe26e2d7f40629cadbb62af058a227
diff --git a/www/p5-HTML-Template/pkg-comment b/www/p5-HTML-Template/pkg-comment
new file mode 100644
index 000000000000..edcad101717a
--- /dev/null
+++ b/www/p5-HTML-Template/pkg-comment
@@ -0,0 +1 @@
+Perl module to use HTML Templates from CGI scripts
diff --git a/www/p5-HTML-Template/pkg-descr b/www/p5-HTML-Template/pkg-descr
new file mode 100644
index 000000000000..a8a3d5fbaef9
--- /dev/null
+++ b/www/p5-HTML-Template/pkg-descr
@@ -0,0 +1,3 @@
+Perl module to use HTML Templates from CGI scripts.
+
+WWW: http://sourceforge.net/projects/html-template/
diff --git a/www/p5-HTML-Template/pkg-plist b/www/p5-HTML-Template/pkg-plist
new file mode 100644
index 000000000000..216ba6c7a889
--- /dev/null
+++ b/www/p5-HTML-Template/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/HTML/Template.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/HTML/Template/.packlist
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/HTML 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/HTML/Template 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/HTML 2>/dev/null || true