aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTML-Template
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2005-06-11 16:13:12 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2005-06-11 16:13:12 +0000
commit54a1630d6e44ec2ef8cb3c4a00d6f4e0503f3b4f (patch)
tree75f8d629d0ebf0e58a1b981a5cffc533b15375cf /www/p5-HTML-Template
parent60cdc5877ab9a2546477d5d754adaa936030b51e (diff)
Notes
Diffstat (limited to 'www/p5-HTML-Template')
-rw-r--r--www/p5-HTML-Template/Makefile21
-rw-r--r--www/p5-HTML-Template/files/patch-Template.pm12
2 files changed, 6 insertions, 27 deletions
diff --git a/www/p5-HTML-Template/Makefile b/www/p5-HTML-Template/Makefile
index 4d63a202e1c3..34564b7ec28a 100644
--- a/www/p5-HTML-Template/Makefile
+++ b/www/p5-HTML-Template/Makefile
@@ -7,6 +7,7 @@
PORTNAME= HTML-Template
PORTVERSION= 2.7
+PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= HTML
@@ -15,22 +16,12 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Perl module to use HTML Templates from CGI scripts
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
PERL_CONFIGURE= yes
MAN3= HTML::Template.3
-post-patch:
- ${PERL} -i -pe 's@%%PERL_INC%%@${SITE_PERL}@' ${WRKSRC}/Template.pm
-
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600 && !exists(${SITE_PERL}/File/Spec.pm)
-BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
-RUN_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
-.endif
-.if ${PERL_LEVEL} < 500800 && !exists(${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm)
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-HTML-Template/files/patch-Template.pm b/www/p5-HTML-Template/files/patch-Template.pm
deleted file mode 100644
index 6c4d3879d1f3..000000000000
--- a/www/p5-HTML-Template/files/patch-Template.pm
+++ /dev/null
@@ -1,12 +0,0 @@
---- Template.pm.orig Fri Jun 18 21:42:06 2004
-+++ Template.pm Fri Jun 25 13:33:50 2004
-@@ -890,7 +890,9 @@
- use strict; # and no funny business, either.
-
- use Carp; # generate better errors with more context
-+BEGIN { unshift(@INC, "%%PERL_INC%%"); }
- use File::Spec; # generate paths that work on all platforms
-+shift(@INC);
- use Digest::MD5 qw(md5_hex); # generate cache keys
-
- # define accessor constants used to improve readability of array