aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTTP-Cache-Transparent
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-10-14 05:03:35 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-10-14 05:03:35 +0000
commitd6b7c5e27e1739982fb399a9dbf701bf5c0f8cdc (patch)
tree87b25da2adb75af1fd89ae53699b87e1c63ad973 /www/p5-HTTP-Cache-Transparent
parent3c6f319da2d683b6839ce19db9227be7ded506de (diff)
downloadports-d6b7c5e27e1739982fb399a9dbf701bf5c0f8cdc.tar.gz
ports-d6b7c5e27e1739982fb399a9dbf701bf5c0f8cdc.zip
Notes
Diffstat (limited to 'www/p5-HTTP-Cache-Transparent')
-rw-r--r--www/p5-HTTP-Cache-Transparent/Makefile24
-rw-r--r--www/p5-HTTP-Cache-Transparent/distinfo2
-rw-r--r--www/p5-HTTP-Cache-Transparent/pkg-descr5
-rw-r--r--www/p5-HTTP-Cache-Transparent/pkg-plist7
4 files changed, 38 insertions, 0 deletions
diff --git a/www/p5-HTTP-Cache-Transparent/Makefile b/www/p5-HTTP-Cache-Transparent/Makefile
new file mode 100644
index 000000000000..72cf78df5f76
--- /dev/null
+++ b/www/p5-HTTP-Cache-Transparent/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-HTTP-Cache-Transparent
+# Date created: 2005-10-14
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP-Cache-Transparent
+PORTVERSION= 0.6
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTTP
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ahze@FreeBSD.org
+COMMENT= Implementation of http get that keeps a local cache of fetched pages
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+MAN3= HTTP::Cache::Transparent.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTTP-Cache-Transparent/distinfo b/www/p5-HTTP-Cache-Transparent/distinfo
new file mode 100644
index 000000000000..464ab19ada0f
--- /dev/null
+++ b/www/p5-HTTP-Cache-Transparent/distinfo
@@ -0,0 +1,2 @@
+MD5 (HTTP-Cache-Transparent-0.6.tar.gz) = 49208c9cd61f8f687c5f5031845c5de2
+SIZE (HTTP-Cache-Transparent-0.6.tar.gz) = 7571
diff --git a/www/p5-HTTP-Cache-Transparent/pkg-descr b/www/p5-HTTP-Cache-Transparent/pkg-descr
new file mode 100644
index 000000000000..7d7dfae3ed0c
--- /dev/null
+++ b/www/p5-HTTP-Cache-Transparent/pkg-descr
@@ -0,0 +1,5 @@
+Implementation of http get that keeps a local cache of fetched pages to
+avoid fetching the same data from the server if it hasn't been updated.
+The cache is stored on disk and is thus persistent between invocations.
+
+WWW: http://search.cpan.org/~mattiash/HTTP-Cache-Transparent/
diff --git a/www/p5-HTTP-Cache-Transparent/pkg-plist b/www/p5-HTTP-Cache-Transparent/pkg-plist
new file mode 100644
index 000000000000..fc2c59401e12
--- /dev/null
+++ b/www/p5-HTTP-Cache-Transparent/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/HTTP/Cache/Transparent.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Cache/Transparent/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Cache/Transparent
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Cache 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/HTTP/Cache 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/HTTP 2>/dev/null || true