aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTTP-CookieJar
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-03-10 03:08:48 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-03-10 03:08:48 +0000
commitaac0294c92f06e5a0990083aa3e629656a13936f (patch)
tree326e6170275f0f47619d74a98bfc92809511a683 /www/p5-HTTP-CookieJar
parentf1b2886ea24ae83e2f05ecb24de1e3369c110f24 (diff)
Notes
Diffstat (limited to 'www/p5-HTTP-CookieJar')
-rw-r--r--www/p5-HTTP-CookieJar/Makefile29
-rw-r--r--www/p5-HTTP-CookieJar/distinfo2
-rw-r--r--www/p5-HTTP-CookieJar/pkg-descr8
-rw-r--r--www/p5-HTTP-CookieJar/pkg-plist7
4 files changed, 46 insertions, 0 deletions
diff --git a/www/p5-HTTP-CookieJar/Makefile b/www/p5-HTTP-CookieJar/Makefile
new file mode 100644
index 000000000000..14c268f3217e
--- /dev/null
+++ b/www/p5-HTTP-CookieJar/Makefile
@@ -0,0 +1,29 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= HTTP-CookieJar
+PORTVERSION= 0.001
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Minimalist HTTP user agent cookie jar
+
+LICENSE= AL2
+
+BUILD_DEPENDS= p5-HTTP-Date>=0:${PORTSDIR}/www/p5-HTTP-Date
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-HTTP-Message>=0:${PORTSDIR}/www/p5-HTTP-Message \
+ p5-Mozilla-PublicSuffix>=0:${PORTSDIR}/dns/p5-Mozilla-PublicSuffix \
+ p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep \
+ p5-Test-Requires>=0:${PORTSDIR}/devel/p5-Test-Requires \
+ p5-Test-Simple>=0.96:${PORTSDIR}/devel/p5-Test-Simple \
+ p5-Time-Mock>=0:${PORTSDIR}/devel/p5-Time-Mock
+
+PERL_CONFIGURE= yes
+
+MAN3= HTTP::CookieJar.3 \
+ HTTP::CookieJar::LWP.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTTP-CookieJar/distinfo b/www/p5-HTTP-CookieJar/distinfo
new file mode 100644
index 000000000000..09d0d0bfe6af
--- /dev/null
+++ b/www/p5-HTTP-CookieJar/distinfo
@@ -0,0 +1,2 @@
+SHA256 (HTTP-CookieJar-0.001.tar.gz) = 94382017177d1d17874ffc33baf8467930977fabb4b11cd69824a33b1b3f5896
+SIZE (HTTP-CookieJar-0.001.tar.gz) = 24697
diff --git a/www/p5-HTTP-CookieJar/pkg-descr b/www/p5-HTTP-CookieJar/pkg-descr
new file mode 100644
index 000000000000..2ec77837247d
--- /dev/null
+++ b/www/p5-HTTP-CookieJar/pkg-descr
@@ -0,0 +1,8 @@
+HTTP::CookieJar implements a minimalist HTTP user agent cookie jar in
+conformance with RFC 6265.
+
+Unlike the commonly used HTTP::Cookies module, this module does not require use
+of HTTP::Request and HTTP::Response objects. An LWP-compatible adapter is
+available as HTTP::CookieJar::LWP.
+
+WWW: http://search.cpan.org/dist/HTTP-CookieJar/
diff --git a/www/p5-HTTP-CookieJar/pkg-plist b/www/p5-HTTP-CookieJar/pkg-plist
new file mode 100644
index 000000000000..76204b936c95
--- /dev/null
+++ b/www/p5-HTTP-CookieJar/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/HTTP/CookieJar.pm
+%%SITE_PERL%%/HTTP/CookieJar/LWP.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/CookieJar/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/CookieJar
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP
+@dirrm %%SITE_PERL%%/HTTP/CookieJar
+@dirrmtry %%SITE_PERL%%/HTTP