aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTTP-Cookies
diff options
context:
space:
mode:
authorFrederic Culot <culot@FreeBSD.org>2011-04-18 08:58:01 +0000
committerFrederic Culot <culot@FreeBSD.org>2011-04-18 08:58:01 +0000
commitfd938f1f6ad7ec5088a8ac5fcc37c06f806ee441 (patch)
treecbcff854fc4e29746aba47b162c4e13c55d4cdda /www/p5-HTTP-Cookies
parent37fbdcbfb5596be8011c4fdc756fe859bd17a013 (diff)
downloadports-fd938f1f6ad7ec5088a8ac5fcc37c06f806ee441.tar.gz
ports-fd938f1f6ad7ec5088a8ac5fcc37c06f806ee441.zip
Notes
Diffstat (limited to 'www/p5-HTTP-Cookies')
-rw-r--r--www/p5-HTTP-Cookies/Makefile27
-rw-r--r--www/p5-HTTP-Cookies/distinfo2
-rw-r--r--www/p5-HTTP-Cookies/pkg-descr5
-rw-r--r--www/p5-HTTP-Cookies/pkg-plist8
4 files changed, 42 insertions, 0 deletions
diff --git a/www/p5-HTTP-Cookies/Makefile b/www/p5-HTTP-Cookies/Makefile
new file mode 100644
index 000000000000..74533060b338
--- /dev/null
+++ b/www/p5-HTTP-Cookies/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-HTTP-Cookies
+# Date created: 2011-04-18
+# Whom: Frederic Culot <culot@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP-Cookies
+PORTVERSION= 6.00
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= HTTP Cookie jars
+
+RUN_DEPENDS= p5-HTTP-Date>=6:${PORTSDIR}/www/p5-HTTP-Date \
+ p5-HTTP-Message>=6:${PORTSDIR}/www/p5-HTTP-Message
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= HTTP::Cookies.3 \
+ HTTP::Cookies::Microsoft.3 \
+ HTTP::Cookies::Netscape.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTTP-Cookies/distinfo b/www/p5-HTTP-Cookies/distinfo
new file mode 100644
index 000000000000..4c24a07406d9
--- /dev/null
+++ b/www/p5-HTTP-Cookies/distinfo
@@ -0,0 +1,2 @@
+SHA256 (HTTP-Cookies-6.00.tar.gz) = 30b5741894696493748336226b91e1a6bda66480f5fa758f5ce10b21f360a81c
+SIZE (HTTP-Cookies-6.00.tar.gz) = 18718
diff --git a/www/p5-HTTP-Cookies/pkg-descr b/www/p5-HTTP-Cookies/pkg-descr
new file mode 100644
index 000000000000..63f710a24c8e
--- /dev/null
+++ b/www/p5-HTTP-Cookies/pkg-descr
@@ -0,0 +1,5 @@
+The HTTP::Cookies class is for objects that represent a "cookie jar" --
+that is, a database of all the HTTP cookies that a given LWP::UserAgent
+object knows about.
+
+WWW: http://search.cpan.org/dist/HTTP-Cookies/
diff --git a/www/p5-HTTP-Cookies/pkg-plist b/www/p5-HTTP-Cookies/pkg-plist
new file mode 100644
index 000000000000..fb6dce591055
--- /dev/null
+++ b/www/p5-HTTP-Cookies/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/HTTP/Cookies.pm
+%%SITE_PERL%%/HTTP/Cookies/Microsoft.pm
+%%SITE_PERL%%/HTTP/Cookies/Netscape.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Cookies/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Cookies
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP
+@dirrm %%SITE_PERL%%/HTTP/Cookies
+@dirrmtry %%SITE_PERL%%/HTTP