aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTTP-Engine/Makefile
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2012-04-21 11:43:18 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2012-04-21 11:43:18 +0000
commitf3a28dc8eabe66c5f1daa7591f9fc16c33dbca59 (patch)
tree021488c5a8c49e15a5879b7cb2e8c84146b62139 /www/p5-HTTP-Engine/Makefile
parentbaea503411b49cca72e4a63cee0758e56b516ca6 (diff)
Notes
Diffstat (limited to 'www/p5-HTTP-Engine/Makefile')
-rw-r--r--www/p5-HTTP-Engine/Makefile28
1 files changed, 15 insertions, 13 deletions
diff --git a/www/p5-HTTP-Engine/Makefile b/www/p5-HTTP-Engine/Makefile
index d2e9ee9383e0..c7b53c36dc52 100644
--- a/www/p5-HTTP-Engine/Makefile
+++ b/www/p5-HTTP-Engine/Makefile
@@ -7,7 +7,7 @@
PORTNAME= HTTP-Engine
PORTVERSION= 0.03005
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -15,19 +15,21 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Perl extension for HTTP Server Engine Drivers
-BUILD_DEPENDS= p5-Any-Moose>=0.13:${PORTSDIR}/devel/p5-Any-Moose \
- p5-CGI-Simple>=1.103:${PORTSDIR}/www/p5-CGI-Simple \
- p5-Filter>0:${PORTSDIR}/devel/p5-Filter \
- p5-HTTP-Body>=1.05:${PORTSDIR}/www/p5-HTTP-Body \
- p5-HTTP-Headers-Fast>=0.11:${PORTSDIR}/www/p5-HTTP-Headers-Fast \
- p5-HTTP-Request-AsCGI>0:${PORTSDIR}/www/p5-HTTP-Request-AsCGI \
- p5-HTTP-Server-Simple>=0.35:${PORTSDIR}/www/p5-HTTP-Server-Simple \
- p5-IO-stringy>=0:${PORTSDIR}/devel/p5-IO-stringy \
- p5-Mouse>=0.62:${PORTSDIR}/devel/p5-Moose \
- p5-MouseX-Types>=0.05:${PORTSDIR}/devel/p5-MouseX-Types \
- p5-URI>=1.36:${PORTSDIR}/net/p5-URI \
- p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML
+BUILD_DEPENDS= \
+ p5-Any-Moose>=0.13:${PORTSDIR}/devel/p5-Any-Moose \
+ p5-CGI-Simple>=1.103:${PORTSDIR}/www/p5-CGI-Simple \
+ p5-Filter>0:${PORTSDIR}/devel/p5-Filter \
+ p5-HTTP-Body>=1.05:${PORTSDIR}/www/p5-HTTP-Body \
+ p5-HTTP-Headers-Fast>=0.11:${PORTSDIR}/www/p5-HTTP-Headers-Fast \
+ p5-HTTP-Server-Simple>=0.35:${PORTSDIR}/www/p5-HTTP-Server-Simple \
+ p5-Mouse>=0.62:${PORTSDIR}/devel/p5-Moose \
+ p5-URI>=1.36:${PORTSDIR}/net/p5-URI
RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= \
+ p5-HTTP-Request-AsCGI>0:${PORTSDIR}/www/p5-HTTP-Request-AsCGI \
+ p5-YAML>0:${PORTSDIR}/textproc/p5-YAML \
+ p5-IO-stringy>0:${PORTSDIR}/devel/p5-IO-stringy \
+ p5-MouseX-Types>=0.05:${PORTSDIR}/devel/p5-MouseX-Types
PERL_CONFIGURE= yes