aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTTP-Engine
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2009-02-16 01:38:28 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2009-02-16 01:38:28 +0000
commitdfcebc24a80f87b5167ce95a3c30acdad4ecc13f (patch)
tree977ebd8295c00a0f872a3021cb39f584913d5c34 /www/p5-HTTP-Engine
parent70b76f9021135a9c7439456b394c407cef6a509d (diff)
downloadports-dfcebc24a80f87b5167ce95a3c30acdad4ecc13f.tar.gz
ports-dfcebc24a80f87b5167ce95a3c30acdad4ecc13f.zip
Notes
Diffstat (limited to 'www/p5-HTTP-Engine')
-rw-r--r--www/p5-HTTP-Engine/Makefile12
-rw-r--r--www/p5-HTTP-Engine/distinfo6
-rw-r--r--www/p5-HTTP-Engine/pkg-plist39
3 files changed, 30 insertions, 27 deletions
diff --git a/www/p5-HTTP-Engine/Makefile b/www/p5-HTTP-Engine/Makefile
index c6291e108a65..61a4f4348db3 100644
--- a/www/p5-HTTP-Engine/Makefile
+++ b/www/p5-HTTP-Engine/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= HTTP-Engine
-PORTVERSION= 0.0.21
+PORTVERSION= 0.1.3
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -15,11 +15,12 @@ MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Perl extension for HTTP Server Engine Drivers
RUN_DEPENDS= \
- p5-Moose>=0.59:${PORTSDIR}/devel/p5-Moose \
- p5-MooseX-Types>=0.04:${PORTSDIR}/devel/p5-MooseX-Types \
+ p5-Mouse>=0.16:${PORTSDIR}/devel/p5-Mouse \
+ p5-MouseX-Types>=0.01:${PORTSDIR}/devel/p5-MouseX-Types \
+ p5-Class-Method-Modifiers>=0:${PORTSDIR}/devel/p5-Class-Method-Modifiers \
p5-CGI-Simple>=1.103:${PORTSDIR}/www/p5-CGI-Simple \
- p5-HTTP-Body>=1.04:${PORTSDIR}/www/p5-HTTP-Body \
- p5-libwww>=5.810:${PORTSDIR}/www/p5-libwww \
+ p5-HTTP-Body>=1.05:${PORTSDIR}/www/p5-HTTP-Body \
+ p5-HTTP-Headers-Fast>=0.05:${PORTSDIR}/www/p5-HTTP-Headers-Fast \
p5-URI>=1.36:${PORTSDIR}/net/p5-URI \
p5-HTTP-Server-Simple>=0.35:${PORTSDIR}/www/p5-HTTP-Server-Simple
BUILD_DEPENDS= ${RUN_DEPENDS}
@@ -35,6 +36,7 @@ MAN3= HTTP::Engine.3 \
HTTP::Engine::Interface::ServerSimple.3 \
HTTP::Engine::Interface::Standalone.3 \
HTTP::Engine::Interface::Test.3 \
+ HTTP::Engine::MinimalCGI.3 \
HTTP::Engine::Request.3 \
HTTP::Engine::Request::Upload.3 \
HTTP::Engine::Response.3 \
diff --git a/www/p5-HTTP-Engine/distinfo b/www/p5-HTTP-Engine/distinfo
index 7ce4e3395887..8cbb3ffc3404 100644
--- a/www/p5-HTTP-Engine/distinfo
+++ b/www/p5-HTTP-Engine/distinfo
@@ -1,3 +1,3 @@
-MD5 (HTTP-Engine-0.0.21.tar.gz) = 764a117168e9e6668fa1b20c077433a7
-SHA256 (HTTP-Engine-0.0.21.tar.gz) = 476a4e703a630bcce21c44d34ac11b4f7d7115ac09dbbf4236d8d3881fb9f804
-SIZE (HTTP-Engine-0.0.21.tar.gz) = 96308
+MD5 (HTTP-Engine-0.1.3.tar.gz) = dbd3a62f81b4a0f9c22049c1194ef447
+SHA256 (HTTP-Engine-0.1.3.tar.gz) = f7c5b25c49f73f72ae14a57a0b879b2f922fc0d8fcac1278f5d6e069d9692764
+SIZE (HTTP-Engine-0.1.3.tar.gz) = 103374
diff --git a/www/p5-HTTP-Engine/pkg-plist b/www/p5-HTTP-Engine/pkg-plist
index 505c4936afd8..98c4cf4f3127 100644
--- a/www/p5-HTTP-Engine/pkg-plist
+++ b/www/p5-HTTP-Engine/pkg-plist
@@ -1,36 +1,37 @@
%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Engine/.packlist
+%%SITE_PERL%%/HTTP/Engine.pm
+%%SITE_PERL%%/HTTP/Engine/Cookbook.pod
+%%SITE_PERL%%/HTTP/Engine/Interface.pm
%%SITE_PERL%%/HTTP/Engine/Interface/CGI.pm
+%%SITE_PERL%%/HTTP/Engine/Interface/FCGI.pm
+%%SITE_PERL%%/HTTP/Engine/Interface/ModPerl.pm
%%SITE_PERL%%/HTTP/Engine/Interface/POE.pm
%%SITE_PERL%%/HTTP/Engine/Interface/ServerSimple.pm
-%%SITE_PERL%%/HTTP/Engine/Interface/ModPerl.pm
-%%SITE_PERL%%/HTTP/Engine/Interface/Test.pm
-%%SITE_PERL%%/HTTP/Engine/Interface/FCGI.pm
%%SITE_PERL%%/HTTP/Engine/Interface/Standalone.pm
+%%SITE_PERL%%/HTTP/Engine/Interface/Test.pm
+%%SITE_PERL%%/HTTP/Engine/MinimalCGI.pm
+%%SITE_PERL%%/HTTP/Engine/Request.pm
%%SITE_PERL%%/HTTP/Engine/Request/Upload.pm
%%SITE_PERL%%/HTTP/Engine/RequestBuilder/CGI.pm
%%SITE_PERL%%/HTTP/Engine/RequestBuilder/NoEnv.pm
-%%SITE_PERL%%/HTTP/Engine/Role/RequestBuilder/ReadBody.pm
-%%SITE_PERL%%/HTTP/Engine/Role/RequestBuilder/NoEnv.pm
+%%SITE_PERL%%/HTTP/Engine/Response.pm
+%%SITE_PERL%%/HTTP/Engine/ResponseFinalizer.pm
+%%SITE_PERL%%/HTTP/Engine/Role/Interface.pm
+%%SITE_PERL%%/HTTP/Engine/Role/Request.pm
+%%SITE_PERL%%/HTTP/Engine/Role/RequestBuilder.pm
%%SITE_PERL%%/HTTP/Engine/Role/RequestBuilder/HTTPBody.pm
+%%SITE_PERL%%/HTTP/Engine/Role/RequestBuilder/NoEnv.pm
%%SITE_PERL%%/HTTP/Engine/Role/RequestBuilder/ParseEnv.pm
+%%SITE_PERL%%/HTTP/Engine/Role/RequestBuilder/ReadBody.pm
%%SITE_PERL%%/HTTP/Engine/Role/RequestBuilder/Standard.pm
-%%SITE_PERL%%/HTTP/Engine/Role/ResponseWriter/WriteSTDOUT.pm
-%%SITE_PERL%%/HTTP/Engine/Role/ResponseWriter/OutputBody.pm
+%%SITE_PERL%%/HTTP/Engine/Role/Response.pm
+%%SITE_PERL%%/HTTP/Engine/Role/ResponseWriter.pm
%%SITE_PERL%%/HTTP/Engine/Role/ResponseWriter/Finalize.pm
+%%SITE_PERL%%/HTTP/Engine/Role/ResponseWriter/OutputBody.pm
+%%SITE_PERL%%/HTTP/Engine/Role/ResponseWriter/OutputHeader.pm
%%SITE_PERL%%/HTTP/Engine/Role/ResponseWriter/ResponseLine.pm
-%%SITE_PERL%%/HTTP/Engine/Role/RequestBuilder.pm
-%%SITE_PERL%%/HTTP/Engine/Role/Request.pm
-%%SITE_PERL%%/HTTP/Engine/Role/Interface.pm
-%%SITE_PERL%%/HTTP/Engine/Role/ResponseWriter.pm
-%%SITE_PERL%%/HTTP/Engine/Role/Response.pm
+%%SITE_PERL%%/HTTP/Engine/Role/ResponseWriter/WriteSTDOUT.pm
%%SITE_PERL%%/HTTP/Engine/Types/Core.pm
-%%SITE_PERL%%/HTTP/Engine/Response.pm
-%%SITE_PERL%%/HTTP/Engine/Cookbook.pod
-%%SITE_PERL%%/HTTP/Engine/Interface.pm
-%%SITE_PERL%%/HTTP/Engine/Request.pm
-%%SITE_PERL%%/HTTP/Engine/Util.pm
-%%SITE_PERL%%/HTTP/Engine/ResponseFinalizer.pm
-%%SITE_PERL%%/HTTP/Engine.pm
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Engine
@dirrm %%SITE_PERL%%/HTTP/Engine/Types
@dirrm %%SITE_PERL%%/HTTP/Engine/Role/ResponseWriter