aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTTP-HeaderParser-XS
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2008-04-18 13:17:14 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2008-04-18 13:17:14 +0000
commitaca7ac20e761c5615b6b7c1094e99601056c9c3b (patch)
treedc9c64b360a62bedc46d2fb7bbc281ee54278ecb /www/p5-HTTP-HeaderParser-XS
parentce7e400fbe65c6c488290a659b39a5f073c7e220 (diff)
downloadports-aca7ac20e761c5615b6b7c1094e99601056c9c3b.tar.gz
ports-aca7ac20e761c5615b6b7c1094e99601056c9c3b.zip
Notes
Diffstat (limited to 'www/p5-HTTP-HeaderParser-XS')
-rw-r--r--www/p5-HTTP-HeaderParser-XS/Makefile23
-rw-r--r--www/p5-HTTP-HeaderParser-XS/distinfo3
-rw-r--r--www/p5-HTTP-HeaderParser-XS/pkg-descr7
-rw-r--r--www/p5-HTTP-HeaderParser-XS/pkg-plist10
4 files changed, 43 insertions, 0 deletions
diff --git a/www/p5-HTTP-HeaderParser-XS/Makefile b/www/p5-HTTP-HeaderParser-XS/Makefile
new file mode 100644
index 000000000000..c88f4fc73c32
--- /dev/null
+++ b/www/p5-HTTP-HeaderParser-XS/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: HTTP-HeaderParser-XS
+# Date created: 18 Apr 2008
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP-HeaderParser-XS
+PORTVERSION= 0.20
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= XS extension for processing HTTP headers
+
+PERL_CONFIGURE= 5.8.1+
+
+MAKE_ARGS+= CC=${CXX} LD=${CXX}
+
+MAN3= HTTP::HeaderParser::XS.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTTP-HeaderParser-XS/distinfo b/www/p5-HTTP-HeaderParser-XS/distinfo
new file mode 100644
index 000000000000..5555b10089aa
--- /dev/null
+++ b/www/p5-HTTP-HeaderParser-XS/distinfo
@@ -0,0 +1,3 @@
+MD5 (HTTP-HeaderParser-XS-0.20.tar.gz) = 1f23fc8193cda15de12e019d2c451b36
+SHA256 (HTTP-HeaderParser-XS-0.20.tar.gz) = a9e00fffb3d8991a14aaafddc61d6d168c4ff14e314ae3dbb2d4da3008d746ef
+SIZE (HTTP-HeaderParser-XS-0.20.tar.gz) = 24257
diff --git a/www/p5-HTTP-HeaderParser-XS/pkg-descr b/www/p5-HTTP-HeaderParser-XS/pkg-descr
new file mode 100644
index 000000000000..92398e9409b6
--- /dev/null
+++ b/www/p5-HTTP-HeaderParser-XS/pkg-descr
@@ -0,0 +1,7 @@
+This module parses HTTP headers using a C++ state machine. The goal is
+to be fast, not necessarily to do everything you could ever want.
+
+Headers are not static, you can parse them, munge them, or even build
+them using this module.
+
+WWW: http://search.cpan.org/dist/HTTP-HeaderParser-XS/
diff --git a/www/p5-HTTP-HeaderParser-XS/pkg-plist b/www/p5-HTTP-HeaderParser-XS/pkg-plist
new file mode 100644
index 000000000000..3f0ba8dfa42c
--- /dev/null
+++ b/www/p5-HTTP-HeaderParser-XS/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/HeaderParser/XS/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/HeaderParser/XS/XS.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/HeaderParser/XS/XS.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/HeaderParser/XS/autosplit.ix
+%%SITE_PERL%%/%%PERL_ARCH%%/HTTP/HeaderParser/XS.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/HTTP/HeaderParser
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/HTTP
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/HeaderParser/XS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/HeaderParser
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP