aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTTP-MobileAgent/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2003-02-27 05:37:23 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2003-02-27 05:37:23 +0000
commit1097f728c6c2bfd5a52458d5b2b714ba169549c6 (patch)
treebbb9126cebd845597529034033e7e61598fe7d0f /www/p5-HTTP-MobileAgent/Makefile
parent7520ee9ed7eb7d47a387ef89e86f1b03b3172a1c (diff)
downloadports-1097f728c6c2bfd5a52458d5b2b714ba169549c6.tar.gz
ports-1097f728c6c2bfd5a52458d5b2b714ba169549c6.zip
Notes
Diffstat (limited to 'www/p5-HTTP-MobileAgent/Makefile')
-rw-r--r--www/p5-HTTP-MobileAgent/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/www/p5-HTTP-MobileAgent/Makefile b/www/p5-HTTP-MobileAgent/Makefile
new file mode 100644
index 000000000000..7e8b45f42ee1
--- /dev/null
+++ b/www/p5-HTTP-MobileAgent/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-HTTP-MobileAgent
+# Date created: 27 February 2003
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP-MobileAgent
+PORTVERSION= 0.08
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTTP
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= An HTTP mobile user agent string parser for Perl
+
+BUILD_DEPENDS= ${PM_DEPENDS}
+RUN_DEPENDS= ${PM_DEPENDS}
+
+PM_DEPENDS= ${SITE_PERL}/HTTP/Headers.pm:${PORTSDIR}/www/p5-libwww
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+
+PERL_CONFIGURE= yes
+
+MAN3= HTTP::MobileAgent.3 \
+ HTTP::MobileAgent::Display.3 \
+ HTTP::MobileAgent::DoCoMo.3 \
+ HTTP::MobileAgent::EZweb.3 \
+ HTTP::MobileAgent::JPhone.3 \
+ HTTP::MobileAgent::NonMobile.3
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>