aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTTP-MobileAttribute
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2009-11-07 14:19:00 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2009-11-07 14:19:00 +0000
commit5f1cac9709c51556e3bceca3d189ac69f61a69fa (patch)
tree95d2a65d1e321e490be15314e9738c462a08aa67 /www/p5-HTTP-MobileAttribute
parent31675b54a23930e5c36382ee927f1cbd5fe2ed8c (diff)
downloadports-5f1cac9709c51556e3bceca3d189ac69f61a69fa.tar.gz
ports-5f1cac9709c51556e3bceca3d189ac69f61a69fa.zip
Notes
Diffstat (limited to 'www/p5-HTTP-MobileAttribute')
-rw-r--r--www/p5-HTTP-MobileAttribute/Makefile43
-rw-r--r--www/p5-HTTP-MobileAttribute/distinfo6
-rw-r--r--www/p5-HTTP-MobileAttribute/pkg-plist49
3 files changed, 60 insertions, 38 deletions
diff --git a/www/p5-HTTP-MobileAttribute/Makefile b/www/p5-HTTP-MobileAttribute/Makefile
index 463234f4088a..e6ffadeb555b 100644
--- a/www/p5-HTTP-MobileAttribute/Makefile
+++ b/www/p5-HTTP-MobileAttribute/Makefile
@@ -6,33 +6,38 @@
#
PORTNAME= HTTP-MobileAttribute
-PORTVERSION= 0.11.1
+PORTVERSION= 0.21
CATEGORIES= www perl5
MASTER_SITES= CPAN
-MASTER_SITE_SUBDIR= ../by-authors/id/T/TO/TOKUHIROM
PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Yet Another HTTP::MobileAgent
-BUILD_DEPENDS= p5-Test-Warn>0:${PORTSDIR}/devel/p5-Test-Warn
-RUN_DEPENDS= p5-Class-Component>=0.15:${PORTSDIR}/devel/p5-Class-Component
-
-MAN3= HTTP::MobileAttribute::Plugin::Encoding.3 \
- HTTP::MobileAttribute::Plugin::IS::DoCoMo.3 \
- HTTP::MobileAttribute::Plugin::CarrierLetter.3 \
- HTTP::MobileAttribute::Plugin::CIDR.3 \
- HTTP::MobileAttribute::Attribute::CarrierMethod.3 \
- HTTP::MobileAttribute::CarrierDetector.3 \
- HTTP::MobileAttribute::Plugin::IS.3 \
- HTTP::MobileAttribute::Plugin::UserID.3 \
- HTTP::MobileAttribute::Plugin::XHTMLCompliant.3 \
- HTTP::MobileAttribute.3 \
- HTTP::MobileAttribute::Plugin::IS::ThirdForce.3 \
- HTTP::MobileAttribute::Plugin::IS::EZweb.3 \
- HTTP::MobileAttribute::Agent::Base.3 \
- HTTP::MobileAttribute::Plugin::Display.3
+RUN_DEPENDS= p5-Class-Component>=0.17:${PORTSDIR}/devel/p5-Class-Component \
+ p5-UNIVERSAL-require>=0.13:${PORTSDIR}/devel/p5-UNIVERSAL-require
+BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS+= p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML
PERL_CONFIGURE= Yes
+MAN3= HTTP::MobileAttribute.3 \
+ HTTP::MobileAttribute::Agent::Base.3 \
+ HTTP::MobileAttribute::Attribute::CarrierMethod.3 \
+ HTTP::MobileAttribute::CarrierDetector.3 \
+ HTTP::MobileAttribute::Plugin::CIDR.3 \
+ HTTP::MobileAttribute::Plugin::CarrierLetter.3 \
+ HTTP::MobileAttribute::Plugin::Display.3 \
+ HTTP::MobileAttribute::Plugin::DoCoMo::Browser.3 \
+ HTTP::MobileAttribute::Plugin::Encoding.3 \
+ HTTP::MobileAttribute::Plugin::GPS.3 \
+ HTTP::MobileAttribute::Plugin::IS.3 \
+ HTTP::MobileAttribute::Plugin::IS::DoCoMo.3 \
+ HTTP::MobileAttribute::Plugin::IS::EZweb.3 \
+ HTTP::MobileAttribute::Plugin::IS::ThirdForce.3 \
+ HTTP::MobileAttribute::Plugin::Locator.3 \
+ HTTP::MobileAttribute::Plugin::UserID.3 \
+ HTTP::MobileAttribute::Plugin::XHTMLCompliant.3
+
.include <bsd.port.mk>
+ \ No newline at end of file
diff --git a/www/p5-HTTP-MobileAttribute/distinfo b/www/p5-HTTP-MobileAttribute/distinfo
index 66283917ab76..33dcfa2441ba 100644
--- a/www/p5-HTTP-MobileAttribute/distinfo
+++ b/www/p5-HTTP-MobileAttribute/distinfo
@@ -1,3 +1,3 @@
-MD5 (HTTP-MobileAttribute-0.11.1.tar.gz) = 1b7eef7b0c650d735d48e60eaab30d54
-SHA256 (HTTP-MobileAttribute-0.11.1.tar.gz) = e7ede20347e6ed53377d16b3083e48822593e7fefe3498a868b651eabbeb3338
-SIZE (HTTP-MobileAttribute-0.11.1.tar.gz) = 58226
+MD5 (HTTP-MobileAttribute-0.21.tar.gz) = f5da1955627f2bd83278a6fd0e4717cb
+SHA256 (HTTP-MobileAttribute-0.21.tar.gz) = 26ee042f9076def1b4d9b7b41bd1eb047df51796d8ccd0801f1717c7cd6deb64
+SIZE (HTTP-MobileAttribute-0.21.tar.gz) = 71454
diff --git a/www/p5-HTTP-MobileAttribute/pkg-plist b/www/p5-HTTP-MobileAttribute/pkg-plist
index 02cebea0aec1..70298ea21f88 100644
--- a/www/p5-HTTP-MobileAttribute/pkg-plist
+++ b/www/p5-HTTP-MobileAttribute/pkg-plist
@@ -1,34 +1,51 @@
-%%SITE_PERL%%/HTTP/MobileAttribute/Agent/DoCoMo.pm
+%%SITE_PERL%%/HTTP/MobileAttribute.pm
%%SITE_PERL%%/HTTP/MobileAttribute/Agent/AirHPhone.pm
-%%SITE_PERL%%/HTTP/MobileAttribute/Agent/EZweb.pm
%%SITE_PERL%%/HTTP/MobileAttribute/Agent/Base.pm
-%%SITE_PERL%%/HTTP/MobileAttribute/Agent/ThirdForce.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Agent/DoCoMo.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Agent/EZweb.pm
%%SITE_PERL%%/HTTP/MobileAttribute/Agent/NonMobile.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Agent/ThirdForce.pm
%%SITE_PERL%%/HTTP/MobileAttribute/Attribute/CarrierMethod.pm
-%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/IS/DoCoMo.pm
-%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/IS/ThirdForce.pm
-%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/IS/EZweb.pm
-%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/Encoding.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/CarrierDetector.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Plugin.pm
%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/CIDR.pm
-%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/Core.pm
%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/CarrierLetter.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/Core.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/Display.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/DoCoMo/Browser.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/Encoding.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/GPS.pm
%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/IS.pm
-%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/XHTMLCompliant.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/IS/DoCoMo.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/IS/EZweb.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/IS/ThirdForce.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/Locator.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/Locator/AirHPhone/BasicLocation.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/Locator/Base.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/Locator/DoCoMo/BasicLocation.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/Locator/DoCoMo/GPS.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/Locator/EZweb/BasicLocation.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/Locator/EZweb/GPS.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/Locator/ThirdForce/BasicLocation.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/Locator/ThirdForce/GPS.pm
%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/UserID.pm
-%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/GPS.pm
-%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/Display.pm
-%%SITE_PERL%%/HTTP/MobileAttribute/Request/HTTPHeaders.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Plugin/XHTMLCompliant.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Request.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Request/APRTable.pm
%%SITE_PERL%%/HTTP/MobileAttribute/Request/Apache.pm
%%SITE_PERL%%/HTTP/MobileAttribute/Request/Env.pm
-%%SITE_PERL%%/HTTP/MobileAttribute/CarrierDetector.pm
-%%SITE_PERL%%/HTTP/MobileAttribute/Plugin.pm
-%%SITE_PERL%%/HTTP/MobileAttribute/Request.pm
-%%SITE_PERL%%/HTTP/MobileAttribute.pm
+%%SITE_PERL%%/HTTP/MobileAttribute/Request/HTTPHeaders.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/MobileAttribute/.packlist
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/MobileAttribute
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP
@dirrmtry %%SITE_PERL%%/HTTP/MobileAttribute/Request
+@dirrmtry %%SITE_PERL%%/HTTP/MobileAttribute/Plugin/Locator/ThirdForce
+@dirrmtry %%SITE_PERL%%/HTTP/MobileAttribute/Plugin/Locator/EZweb
+@dirrmtry %%SITE_PERL%%/HTTP/MobileAttribute/Plugin/Locator/DoCoMo
+@dirrmtry %%SITE_PERL%%/HTTP/MobileAttribute/Plugin/Locator/AirHPhone
+@dirrmtry %%SITE_PERL%%/HTTP/MobileAttribute/Plugin/Locator
@dirrmtry %%SITE_PERL%%/HTTP/MobileAttribute/Plugin/IS
+@dirrmtry %%SITE_PERL%%/HTTP/MobileAttribute/Plugin/DoCoMo
@dirrmtry %%SITE_PERL%%/HTTP/MobileAttribute/Plugin
@dirrmtry %%SITE_PERL%%/HTTP/MobileAttribute/Attribute
@dirrmtry %%SITE_PERL%%/HTTP/MobileAttribute/Agent