aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTTP-Proxy
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2005-04-05 11:03:43 +0000
committerMathieu Arnold <mat@FreeBSD.org>2005-04-05 11:03:43 +0000
commit1b5b0693d9e6d11a7b51e9fdc3c52637dcf03f10 (patch)
tree0a0b0fb8b8b56e93651bee9343458c7698392e76 /www/p5-HTTP-Proxy
parent8a9cbf0da0a5f2d67d8efd43efd2148994cc5939 (diff)
downloadports-1b5b0693d9e6d11a7b51e9fdc3c52637dcf03f10.tar.gz
ports-1b5b0693d9e6d11a7b51e9fdc3c52637dcf03f10.zip
Notes
Diffstat (limited to 'www/p5-HTTP-Proxy')
-rw-r--r--www/p5-HTTP-Proxy/Makefile9
-rw-r--r--www/p5-HTTP-Proxy/distinfo4
-rw-r--r--www/p5-HTTP-Proxy/files/5.005-Makefile.PL24
-rw-r--r--www/p5-HTTP-Proxy/files/5.005-lib::HTTP::Proxy.pm11
-rw-r--r--www/p5-HTTP-Proxy/files/5.005-lib::HTTP::Proxy::BodyFilter::htmltext.pm11
-rw-r--r--www/p5-HTTP-Proxy/pkg-plist2
6 files changed, 9 insertions, 52 deletions
diff --git a/www/p5-HTTP-Proxy/Makefile b/www/p5-HTTP-Proxy/Makefile
index 8ec2c992f7db..82837d0446fa 100644
--- a/www/p5-HTTP-Proxy/Makefile
+++ b/www/p5-HTTP-Proxy/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= HTTP-Proxy
-PORTVERSION= 0.13
+PORTVERSION= 0.14
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= HTTP
@@ -18,14 +18,16 @@ COMMENT= A pure Perl HTTP proxy
BUILD_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+PERL_MODBUILD= yes
MAN3= \
HTTP::Proxy.3 \
HTTP::Proxy::BodyFilter.3 \
+ HTTP::Proxy::BodyFilter::complete.3 \
HTTP::Proxy::BodyFilter::htmlparser.3 \
HTTP::Proxy::BodyFilter::htmltext.3 \
HTTP::Proxy::BodyFilter::lines.3 \
+ HTTP::Proxy::BodyFilter::save.3 \
HTTP::Proxy::BodyFilter::simple.3 \
HTTP::Proxy::BodyFilter::tags.3 \
HTTP::Proxy::HeaderFilter.3 \
@@ -36,10 +38,9 @@ MAN3= \
.if ${PERL_LEVEL} < 500600
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/IO/Socket/INET.pm:${PORTSDIR}/devel/p5-IO
-EXTRA_PATCHES= ${PATCHDIR}/5.005-Makefile.PL ${PATCHDIR}/5.005-lib::HTTP::Proxy.pm ${PATCHDIR}/5.005-lib::HTTP::Proxy::BodyFilter::htmltext.pm
post-patch:
- @${FIND} ${WRKSRC} -name '*.orig' -delete
+ @${PERL} -i -pe '$$_ = "" if /use warnings/' ${WRKSRC}/Build.PL
.endif
.include <bsd.port.post.mk>
diff --git a/www/p5-HTTP-Proxy/distinfo b/www/p5-HTTP-Proxy/distinfo
index 9647e786998c..bf4b794fbf49 100644
--- a/www/p5-HTTP-Proxy/distinfo
+++ b/www/p5-HTTP-Proxy/distinfo
@@ -1,2 +1,2 @@
-MD5 (HTTP-Proxy-0.13.tar.gz) = 377756e947cee91d93c12927a78d88c8
-SIZE (HTTP-Proxy-0.13.tar.gz) = 38958
+MD5 (HTTP-Proxy-0.14.tar.gz) = d6fcfb1137a5edff172414c54afbe9a7
+SIZE (HTTP-Proxy-0.14.tar.gz) = 48915
diff --git a/www/p5-HTTP-Proxy/files/5.005-Makefile.PL b/www/p5-HTTP-Proxy/files/5.005-Makefile.PL
deleted file mode 100644
index 82c310ed197b..000000000000
--- a/www/p5-HTTP-Proxy/files/5.005-Makefile.PL
+++ /dev/null
@@ -1,24 +0,0 @@
---- Makefile.PL~ Tue Mar 23 17:31:09 2004
-+++ Makefile.PL Tue Mar 23 17:31:28 2004
-@@ -1,5 +1,21 @@
- use ExtUtils::MakeMaker;
-
-+if ($] < 5.006) {
-+ for my $f (<lib/HTTP/Proxy/*/*.pm>) {
-+ open F,$f;
-+ my @f = <F>;
-+ close F;
-+ for (@f) {
-+ if (/^use base qw\( (.*) \);/o) {
-+ $_ = "use $1;\nuse vars '\@ISA';\n\@ISA = qw( $1 );\n";
-+ }
-+ }
-+ open F, ">$f";
-+ print F @f;
-+ close F;
-+ }
-+}
-+
- WriteMakefile(
- NAME => 'HTTP::Proxy',
- VERSION_FROM => 'lib/HTTP/Proxy.pm',
diff --git a/www/p5-HTTP-Proxy/files/5.005-lib::HTTP::Proxy.pm b/www/p5-HTTP-Proxy/files/5.005-lib::HTTP::Proxy.pm
deleted file mode 100644
index 7c411926a427..000000000000
--- a/www/p5-HTTP-Proxy/files/5.005-lib::HTTP::Proxy.pm
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/HTTP/Proxy.pm~ Wed Mar 3 01:15:02 2004
-+++ lib/HTTP/Proxy.pm Tue Mar 23 17:54:31 2004
-@@ -760,7 +760,7 @@
- # proxy the data
- $self->log( CONNECT, "($$) CONNECT:",
- "$read bytes received from $from" );
-- $peer->syswrite($data);
-+ $peer->syswrite($data, length($data));
- }
- }
- $self->log( CONNECT, "($$) CONNECT:", "End of CONNECT proxyfication");
diff --git a/www/p5-HTTP-Proxy/files/5.005-lib::HTTP::Proxy::BodyFilter::htmltext.pm b/www/p5-HTTP-Proxy/files/5.005-lib::HTTP::Proxy::BodyFilter::htmltext.pm
deleted file mode 100644
index 46080aa27c51..000000000000
--- a/www/p5-HTTP-Proxy/files/5.005-lib::HTTP::Proxy::BodyFilter::htmltext.pm
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/HTTP/Proxy/BodyFilter/htmltext.pm~ Tue Mar 23 17:51:08 2004
-+++ lib/HTTP/Proxy/BodyFilter/htmltext.pm Tue Mar 23 17:53:30 2004
-@@ -66,7 +66,7 @@
- redo SCAN if $self->{js}; # ignore protected
- {
- local $_ = $1;
-- $self->{_filter}();
-+ $self->{_filter}->();
- substr( $$dataref, $pos, length($1), $_ );
- pos($$dataref) = $pos + length($_);
- }
diff --git a/www/p5-HTTP-Proxy/pkg-plist b/www/p5-HTTP-Proxy/pkg-plist
index 3161dc32ca1d..2ba3f5c9af2e 100644
--- a/www/p5-HTTP-Proxy/pkg-plist
+++ b/www/p5-HTTP-Proxy/pkg-plist
@@ -1,8 +1,10 @@
%%SITE_PERL%%/HTTP/Proxy.pm
%%SITE_PERL%%/HTTP/Proxy/BodyFilter.pm
+%%SITE_PERL%%/HTTP/Proxy/BodyFilter/complete.pm
%%SITE_PERL%%/HTTP/Proxy/BodyFilter/htmlparser.pm
%%SITE_PERL%%/HTTP/Proxy/BodyFilter/htmltext.pm
%%SITE_PERL%%/HTTP/Proxy/BodyFilter/lines.pm
+%%SITE_PERL%%/HTTP/Proxy/BodyFilter/save.pm
%%SITE_PERL%%/HTTP/Proxy/BodyFilter/simple.pm
%%SITE_PERL%%/HTTP/Proxy/BodyFilter/tags.pm
%%SITE_PERL%%/HTTP/Proxy/HeaderFilter.pm