aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTTP-Recorder
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-04-24 19:17:53 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-04-24 19:17:53 +0000
commitf2a5392b233c819757a47a122c9d3fc760133df6 (patch)
tree25ae372b8cad1ba5c0d70e28598375ac4f387a7f /www/p5-HTTP-Recorder
parent46ce3512d4b54ca6c3060dc802c22bf034e44c41 (diff)
downloadports-f2a5392b233c819757a47a122c9d3fc760133df6.tar.gz
ports-f2a5392b233c819757a47a122c9d3fc760133df6.zip
Notes
Diffstat (limited to 'www/p5-HTTP-Recorder')
-rw-r--r--www/p5-HTTP-Recorder/Makefile16
-rw-r--r--www/p5-HTTP-Recorder/distinfo4
-rw-r--r--www/p5-HTTP-Recorder/files/patch-lib_HTTP_Recorder.pm25
-rw-r--r--www/p5-HTTP-Recorder/pkg-plist1
4 files changed, 23 insertions, 23 deletions
diff --git a/www/p5-HTTP-Recorder/Makefile b/www/p5-HTTP-Recorder/Makefile
index cb7dc4f74195..6a23f4aff209 100644
--- a/www/p5-HTTP-Recorder/Makefile
+++ b/www/p5-HTTP-Recorder/Makefile
@@ -6,26 +6,28 @@
#
PORTNAME= HTTP-Recorder
-PORTVERSION= 0.05
-PORTREVISION= 1
+PORTVERSION= 0.06
CATEGORIES= www perl5
MASTER_SITES= CPAN
-MASTER_SITE_SUBDIR= CPAN:LEIRA
PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Record interaction with websites
-BUILD_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/${PERL_ARCH}/HTML/TokeParser.pm:${PORTSDIR}/www/p5-HTML-Parser \
- ${SITE_PERL}/HTTP/Request/Params.pm:${PORTSDIR}/www/p5-HTTP-Request-Params
+BUILD_DEPENDS= p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
+ p5-HTTP-Proxy>=0:${PORTSDIR}/www/p5-HTTP-Proxy \
+ p5-HTTP-Request-Params>=0:${PORTSDIR}/www/p5-HTTP-Request-Params \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
+USE_DOS2UNIX= yes
+MAN1= httprecorder.1
MAN3= HTTP::Recorder.3
post-patch:
- ${RM} -f ${WRKSRC}/lib/HTTP/Recorder.pm.orig
+ @${RM} -f ${WRKSRC}/lib/HTTP/Recorder.pm.orig
.include <bsd.port.mk>
diff --git a/www/p5-HTTP-Recorder/distinfo b/www/p5-HTTP-Recorder/distinfo
index a40f29910a5f..936ca6745a59 100644
--- a/www/p5-HTTP-Recorder/distinfo
+++ b/www/p5-HTTP-Recorder/distinfo
@@ -1,2 +1,2 @@
-SHA256 (HTTP-Recorder-0.05.tar.gz) = a6ee3139b63fb35308ef4f7192490d53085c66c77f9bae672ffe521b633aa689
-SIZE (HTTP-Recorder-0.05.tar.gz) = 9604
+SHA256 (HTTP-Recorder-0.06.tar.gz) = c5fe788d7a9d1e24398e89d7f5cbcd9c467ad7a34b33dd585a48ea2ab79c623b
+SIZE (HTTP-Recorder-0.06.tar.gz) = 10872
diff --git a/www/p5-HTTP-Recorder/files/patch-lib_HTTP_Recorder.pm b/www/p5-HTTP-Recorder/files/patch-lib_HTTP_Recorder.pm
index 9227e5f7a31b..cff42d9fd721 100644
--- a/www/p5-HTTP-Recorder/files/patch-lib_HTTP_Recorder.pm
+++ b/www/p5-HTTP-Recorder/files/patch-lib_HTTP_Recorder.pm
@@ -1,25 +1,22 @@
-
$FreeBSD$
---- lib/HTTP/Recorder.pm.orig
-+++ lib/HTTP/Recorder.pm
-@@ -344,12 +344,13 @@
- # get rid of the arguments we added
- my $prefix = $self->{prefix};
+--- lib/HTTP/Recorder.pm.orig 2012-04-23 22:20:16.000000000 +0800
++++ lib/HTTP/Recorder.pm 2012-04-25 01:11:56.207852080 +0800
+@@ -352,11 +352,12 @@
+ return $content;
+ }
- for my $key ($content->query_param) {
- if ($key =~ /^$prefix-/) {
- $content->query_param_delete($key);
- }
- }
-- return $content;
-+ $content =~ s/$prefix-(.*?)\?(.*?)&//g;
-+ $content =~ s/$prefix-(.*?)&//g;
-+ $content =~ s/$prefix-(.*?)$//g;
-+ $content =~ s/&$//g;
-+ $content =~ s/\?$//g;
++ $content =~ s/$prefix-(.*?)\?(.*?)&//g;
++ $content =~ s/$prefix-(.*?)&//g;
++ $content =~ s/$prefix-(.*?)$//g;
++ $content =~ s/&$//g;
++ $content =~ s/\?$//g;
+
-+ return $content;
+ return $content;
}
- sub extract_values {
diff --git a/www/p5-HTTP-Recorder/pkg-plist b/www/p5-HTTP-Recorder/pkg-plist
index 6d6f2c05d76d..7e64afa22ed7 100644
--- a/www/p5-HTTP-Recorder/pkg-plist
+++ b/www/p5-HTTP-Recorder/pkg-plist
@@ -1,3 +1,4 @@
+bin/httprecorder
%%SITE_PERL%%/HTTP/Recorder.pm
%%SITE_PERL%%/HTTP/Recorder/Logger.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Recorder/.packlist