aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTTP-Request-Params
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2005-11-22 13:10:26 +0000
committerMathieu Arnold <mat@FreeBSD.org>2005-11-22 13:10:26 +0000
commit1a5091d4e89176c1dd79ea73ab2bee87fdc064af (patch)
treea3dbc754031e5cfe2e0fce0bd81b3c0a26c6ca4c /www/p5-HTTP-Request-Params
parentd72bdd7d1bd1b2c2ecda4ee007f2e259f9ebcf9e (diff)
downloadports-1a5091d4e89176c1dd79ea73ab2bee87fdc064af.tar.gz
ports-1a5091d4e89176c1dd79ea73ab2bee87fdc064af.zip
Notes
Diffstat (limited to 'www/p5-HTTP-Request-Params')
-rw-r--r--www/p5-HTTP-Request-Params/Makefile37
-rw-r--r--www/p5-HTTP-Request-Params/distinfo3
-rw-r--r--www/p5-HTTP-Request-Params/pkg-descr8
-rw-r--r--www/p5-HTTP-Request-Params/pkg-plist8
4 files changed, 56 insertions, 0 deletions
diff --git a/www/p5-HTTP-Request-Params/Makefile b/www/p5-HTTP-Request-Params/Makefile
new file mode 100644
index 000000000000..20f053cfd2d3
--- /dev/null
+++ b/www/p5-HTTP-Request-Params/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: p5-HTTP-Request-Params
+# Date created: 22 Nov 2005
+# Whom: mat
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP-Request-Params
+PORTVERSION= 1.01
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTTP
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Retrieve GET/POST Parameters from HTTP Requests
+
+BUILD_DEPENDS= ${SITE_PERL}/CGI.pm:${PORTSDIR}/www/p5-CGI.pm \
+ ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/Email/MIME/Modifier.pm:${PORTSDIR}/mail/p5-Email-MIME-Modifier \
+ ${SITE_PERL}/HTTP/Request/Common.pm:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= HTTP::Request::Params.3
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= Changes README
+
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTTP-Request-Params/distinfo b/www/p5-HTTP-Request-Params/distinfo
new file mode 100644
index 000000000000..3021f2f44ece
--- /dev/null
+++ b/www/p5-HTTP-Request-Params/distinfo
@@ -0,0 +1,3 @@
+MD5 (HTTP-Request-Params-1.01.tar.gz) = fccd255a2992c77b5c40cb5e1e75b256
+SHA256 (HTTP-Request-Params-1.01.tar.gz) = 0ca6d66e0f87bccac54f06147af4aa93f4f65f683b3191320f0b846a7449bc09
+SIZE (HTTP-Request-Params-1.01.tar.gz) = 3427
diff --git a/www/p5-HTTP-Request-Params/pkg-descr b/www/p5-HTTP-Request-Params/pkg-descr
new file mode 100644
index 000000000000..2a31a54d02cb
--- /dev/null
+++ b/www/p5-HTTP-Request-Params/pkg-descr
@@ -0,0 +1,8 @@
+This software does all the dirty work of parsing HTTP Requests to find incoming
+query parameters.
+
+Incoming query parameters come from two places. The first place is the query
+portion of the URL. Second is the content portion of an HTTP request as is the
+case when parsing a POST request, for example.
+
+WWW: http://search.cpan.org/dist/HTTP-Request-Params/
diff --git a/www/p5-HTTP-Request-Params/pkg-plist b/www/p5-HTTP-Request-Params/pkg-plist
new file mode 100644
index 000000000000..3533d30f9973
--- /dev/null
+++ b/www/p5-HTTP-Request-Params/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/HTTP/Request/Params.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Request/Params/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Request/Params
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Request 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/HTTP/Request 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/HTTP 2>/dev/null || true