aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTTP-Server-Simple-Mason/Makefile
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2005-04-28 08:37:51 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2005-04-28 08:37:51 +0000
commit4a40e3b92918f16c1b8dbd3027c42a0d6ad3d530 (patch)
treec8aa5b5262fd0cf1edeb4b78056ccb739e3e9b51 /www/p5-HTTP-Server-Simple-Mason/Makefile
parentf0ba9c83e5a9b2e7b01f24d5aafa5bab0339cef8 (diff)
downloadports-4a40e3b92918f16c1b8dbd3027c42a0d6ad3d530.tar.gz
ports-4a40e3b92918f16c1b8dbd3027c42a0d6ad3d530.zip
Notes
Diffstat (limited to 'www/p5-HTTP-Server-Simple-Mason/Makefile')
-rw-r--r--www/p5-HTTP-Server-Simple-Mason/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/www/p5-HTTP-Server-Simple-Mason/Makefile b/www/p5-HTTP-Server-Simple-Mason/Makefile
new file mode 100644
index 000000000000..7217ba076319
--- /dev/null
+++ b/www/p5-HTTP-Server-Simple-Mason/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: HTTP::Server::Simple::Mason
+# Date created: 28 April 2005
+# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP-Server-Simple-Mason
+PORTVERSION= 0.03
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTTP
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= demon@FreeBSD.org
+COMMENT= An abstract baseclass for a standalone mason server
+
+RUN_DEPENDS= ${SITE_PERL}/HTTP/Server/Simple.pm:${PORTSDIR}/www/p5-HTTP-Server-Simple \
+ ${SITE_PERL}/Apache/Mason.pm:${PORTSDIR}/www/p5-HTML-Mason
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE=yes
+
+MAN3= HTTP::Server::Simple::Mason.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires Perl 5.6 or newer. Install lang/perl5 or lang/perl5.8, and try again
+.endif
+
+.include <bsd.port.post.mk>