aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTTP-Server-Simple
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2005-04-02 11:36:40 +0000
committerLars Thegler <lth@FreeBSD.org>2005-04-02 11:36:40 +0000
commit6b94fabddb9a7b2773a06616067bf69bd368fdfd (patch)
tree542596f7a3565afabe1e897ed88ae38f44a852d3 /www/p5-HTTP-Server-Simple
parent8e9971e7616c07269eeb6f28d9ad69992d037445 (diff)
downloadports-6b94fabddb9a7b2773a06616067bf69bd368fdfd.tar.gz
ports-6b94fabddb9a7b2773a06616067bf69bd368fdfd.zip
Notes
Diffstat (limited to 'www/p5-HTTP-Server-Simple')
-rw-r--r--www/p5-HTTP-Server-Simple/Makefile27
-rw-r--r--www/p5-HTTP-Server-Simple/distinfo2
-rw-r--r--www/p5-HTTP-Server-Simple/pkg-descr5
-rw-r--r--www/p5-HTTP-Server-Simple/pkg-plist9
4 files changed, 43 insertions, 0 deletions
diff --git a/www/p5-HTTP-Server-Simple/Makefile b/www/p5-HTTP-Server-Simple/Makefile
new file mode 100644
index 000000000000..2452f9c3052c
--- /dev/null
+++ b/www/p5-HTTP-Server-Simple/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: www/p5-HTTP-Server-Simple
+# Date created: 30 March 2005
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP-Server-Simple
+PORTVERSION= 0.07
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTTP
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= A very simple standalone HTTP daemon
+
+PERL_CONFIGURE= yes
+
+MAN3= HTTP::Server::Simple.3 \
+ HTTP::Server::Simple::CGI.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires Perl 5.6 or newer. Install lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-HTTP-Server-Simple/distinfo b/www/p5-HTTP-Server-Simple/distinfo
new file mode 100644
index 000000000000..e76cb9004cfc
--- /dev/null
+++ b/www/p5-HTTP-Server-Simple/distinfo
@@ -0,0 +1,2 @@
+MD5 (HTTP-Server-Simple-0.07.tar.gz) = f793978a69578c9682e1d8b11629ebab
+SIZE (HTTP-Server-Simple-0.07.tar.gz) = 16739
diff --git a/www/p5-HTTP-Server-Simple/pkg-descr b/www/p5-HTTP-Server-Simple/pkg-descr
new file mode 100644
index 000000000000..790a8e0a88ea
--- /dev/null
+++ b/www/p5-HTTP-Server-Simple/pkg-descr
@@ -0,0 +1,5 @@
+HTTP::Server::Simple is a very simple standalone HTTP daemon with
+no non-core module dependencies. It's ideal for building a standalone
+http-based UI to your existing tools.
+
+WWW: http://search.cpan.org/dist/HTTP-Server-Simple
diff --git a/www/p5-HTTP-Server-Simple/pkg-plist b/www/p5-HTTP-Server-Simple/pkg-plist
new file mode 100644
index 000000000000..5b6c8f3d1bff
--- /dev/null
+++ b/www/p5-HTTP-Server-Simple/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/HTTP/Server/Simple.pm
+%%SITE_PERL%%/HTTP/Server/Simple/CGI.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Server/Simple/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Server/Simple 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Server 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/HTTP/Server/Simple 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/HTTP/Server 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/HTTP 2>/dev/null || true