aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTTP-Session/Makefile
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2009-01-22 00:59:20 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2009-01-22 00:59:20 +0000
commitc8e83b865181e27c3ccf103049f3668bd253f4e3 (patch)
treee149e00d6401e62dd0fe7d9746ce20480e3ae327 /www/p5-HTTP-Session/Makefile
parent8e5f454ba99da876270ac268d97bab3c48f5109e (diff)
downloadports-c8e83b865181e27c3ccf103049f3668bd253f4e3.tar.gz
ports-c8e83b865181e27c3ccf103049f3668bd253f4e3.zip
Notes
Diffstat (limited to 'www/p5-HTTP-Session/Makefile')
-rw-r--r--www/p5-HTTP-Session/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/www/p5-HTTP-Session/Makefile b/www/p5-HTTP-Session/Makefile
new file mode 100644
index 000000000000..c3d418abb126
--- /dev/null
+++ b/www/p5-HTTP-Session/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: HTTP::Session
+# Date created: 22 Jan 2009
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP-Session
+PORTVERSION= 0.28
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension of yet another session manager
+
+RUN_DEPENDS= \
+ p5-Class-Accessor>=0.31:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-CGI-Simple>=1.103:${PORTSDIR}/www/p5-CGI-Simple \
+ p5-Digest-SHA1>=2.11:${PORTSDIR}/security/p5-Digest-SHA1 \
+ p5-libwww>=5.818:${PORTSDIR}/www/p5-libwww \
+ p5-UNIVERSAL-require>=0.05:${PORTSDIR}/devel/p5-UNIVERSAL-require
+
+PERL_CONFIGURE= yes
+
+MAN3= HTTP::Session.3 \
+ HTTP::Session::State::Cookie.3 \
+ HTTP::Session::State::GUID.3 \
+ HTTP::Session::State::MobileAgentID.3 \
+ HTTP::Session::State::MobileAttributeID.3 \
+ HTTP::Session::State::Null.3 \
+ HTTP::Session::State::Test.3 \
+ HTTP::Session::State::URI.3 \
+ HTTP::Session::Store::CHI.3 \
+ HTTP::Session::Store::DBM.3 \
+ HTTP::Session::Store::File.3 \
+ HTTP::Session::Store::Memcached.3 \
+ HTTP::Session::Store::Null.3 \
+ HTTP::Session::Store::OnMemory.3 \
+ HTTP::Session::Store::Test.3
+
+.include <bsd.port.mk>