aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTTP-SimpleLinkChecker
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-06-19 06:59:11 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-06-19 06:59:11 +0000
commitddd585c900e1a38a1c95d690681bf6d72974fa72 (patch)
tree3d199e6cfc94c796458dfa17d908dd7ea227ffcf /www/p5-HTTP-SimpleLinkChecker
parent619d2397ad5168af9841cdb208c8886f6a81c4d4 (diff)
downloadports-ddd585c900e1a38a1c95d690681bf6d72974fa72.tar.gz
ports-ddd585c900e1a38a1c95d690681bf6d72974fa72.zip
Notes
Diffstat (limited to 'www/p5-HTTP-SimpleLinkChecker')
-rw-r--r--www/p5-HTTP-SimpleLinkChecker/Makefile31
-rw-r--r--www/p5-HTTP-SimpleLinkChecker/distinfo3
-rw-r--r--www/p5-HTTP-SimpleLinkChecker/pkg-descr21
-rw-r--r--www/p5-HTTP-SimpleLinkChecker/pkg-plist5
4 files changed, 60 insertions, 0 deletions
diff --git a/www/p5-HTTP-SimpleLinkChecker/Makefile b/www/p5-HTTP-SimpleLinkChecker/Makefile
new file mode 100644
index 000000000000..4c241e4ec60b
--- /dev/null
+++ b/www/p5-HTTP-SimpleLinkChecker/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-HTTP-SimpleLinkChecker
+# Date created: 19 Jun 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP-SimpleLinkChecker
+PORTVERSION= 1.10
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTTP
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Check the HTTP response code for a link
+
+BUILD_DEPENDS= p5-libwww>0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= HTTP::SimpleLinkChecker.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600 # inherited from p5-libwww
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-HTTP-SimpleLinkChecker/distinfo b/www/p5-HTTP-SimpleLinkChecker/distinfo
new file mode 100644
index 000000000000..5c5a502eb73c
--- /dev/null
+++ b/www/p5-HTTP-SimpleLinkChecker/distinfo
@@ -0,0 +1,3 @@
+MD5 (HTTP-SimpleLinkChecker-1.10.tar.gz) = f21202e45e6d8faf093b461baff8ea21
+SHA256 (HTTP-SimpleLinkChecker-1.10.tar.gz) = 9af8590f88f20ca28b436a9abc433fcf4b154f407244649b09994432c4483e4f
+SIZE (HTTP-SimpleLinkChecker-1.10.tar.gz) = 4131
diff --git a/www/p5-HTTP-SimpleLinkChecker/pkg-descr b/www/p5-HTTP-SimpleLinkChecker/pkg-descr
new file mode 100644
index 000000000000..48f057173e2a
--- /dev/null
+++ b/www/p5-HTTP-SimpleLinkChecker/pkg-descr
@@ -0,0 +1,21 @@
+You don't have to know anything about objected-oriented Perl, LWP, or the
+HTTP module to be able to check your links. This module is designed for
+the casual user. It has one function, check_link, that returns the HTTP
+response code that it receives when it tries to fetch the web address
+passed to it. The undef value is returned for any non-HTTP failure and the
+$HTTP::SimpleLinkChecker::ERROR variable is set.
+
+The HEAD method is tried first, although if anything other than a good
+status code (those less than 400) is received, another request is made
+with the GET method. Note, however, that even with the best code, no
+module can control how servers decide to respond to a check, or control
+any of the myriad things that can go wrong with the network between you
+and the remote server. Some may filter requests based on origin IP
+address, user-agent type, or any other arbitrary factor. Some servers may
+not respond correctly at all. Furthermore, some servers might be
+temporarily down or overloaded. I recommend that you recheck "broken"
+links a couple times over a long period (like a day or two) before you
+decide they are really broken.
+
+WWW: http://search.cpan.org/dist/HTTP-SimpleLinkChecker
+Author: brian d foy <bdfoy@cpan.org>
diff --git a/www/p5-HTTP-SimpleLinkChecker/pkg-plist b/www/p5-HTTP-SimpleLinkChecker/pkg-plist
new file mode 100644
index 000000000000..a934595614d9
--- /dev/null
+++ b/www/p5-HTTP-SimpleLinkChecker/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/HTTP/SimpleLinkChecker.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/SimpleLinkChecker/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/SimpleLinkChecker
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP
+@dirrmtry %%SITE_PERL%%/HTTP