aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTTPD-Log-Filter
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2002-02-15 14:45:38 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2002-02-15 14:45:38 +0000
commita0eed2015a4b372100157bdf90bae34e4b5a4bcf (patch)
tree6e1edff65a2b48bff22e4855493b9a2bc0db746d /www/p5-HTTPD-Log-Filter
parentfa777add9769c7c02573aaad42f5c978d6472046 (diff)
downloadports-a0eed2015a4b372100157bdf90bae34e4b5a4bcf.tar.gz
ports-a0eed2015a4b372100157bdf90bae34e4b5a4bcf.zip
Notes
Diffstat (limited to 'www/p5-HTTPD-Log-Filter')
-rw-r--r--www/p5-HTTPD-Log-Filter/Makefile25
-rw-r--r--www/p5-HTTPD-Log-Filter/distinfo1
-rw-r--r--www/p5-HTTPD-Log-Filter/pkg-comment1
-rw-r--r--www/p5-HTTPD-Log-Filter/pkg-descr14
-rw-r--r--www/p5-HTTPD-Log-Filter/pkg-plist8
5 files changed, 49 insertions, 0 deletions
diff --git a/www/p5-HTTPD-Log-Filter/Makefile b/www/p5-HTTPD-Log-Filter/Makefile
new file mode 100644
index 000000000000..0d7d031c0550
--- /dev/null
+++ b/www/p5-HTTPD-Log-Filter/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: HTTPD::Log::Filter
+# Date created: 15 Feb 2002
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTPD-Log-Filter
+PORTVERSION= 1.07
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/A/AW/AWRIGLEY
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/IO/Zlib.pm:${PORTSDIR}/archivers/p5-IO-Zlib
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/IO/Zlib.pm:${PORTSDIR}/archivers/p5-IO-Zlib
+
+PERL_CONFIGURE= yes
+MAN1= exclude_robots.1
+MAN3= HTTPD::Log::Filter.3
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTTPD-Log-Filter/distinfo b/www/p5-HTTPD-Log-Filter/distinfo
new file mode 100644
index 000000000000..ac9b049204e2
--- /dev/null
+++ b/www/p5-HTTPD-Log-Filter/distinfo
@@ -0,0 +1 @@
+MD5 (HTTPD-Log-Filter-1.07.tar.gz) = b9f3a3af0dc8973e137016e23cecedcc
diff --git a/www/p5-HTTPD-Log-Filter/pkg-comment b/www/p5-HTTPD-Log-Filter/pkg-comment
new file mode 100644
index 000000000000..72ecf78e2a62
--- /dev/null
+++ b/www/p5-HTTPD-Log-Filter/pkg-comment
@@ -0,0 +1 @@
+Perl module to filter entries out of an httpd log
diff --git a/www/p5-HTTPD-Log-Filter/pkg-descr b/www/p5-HTTPD-Log-Filter/pkg-descr
new file mode 100644
index 000000000000..ab29e501aece
--- /dev/null
+++ b/www/p5-HTTPD-Log-Filter/pkg-descr
@@ -0,0 +1,14 @@
+This module provide a simple interface to filter entries out
+of an httpd logfile. The constructor can be passed regular
+expressions to match against particular fields on the
+logfile. It does its filtering line by line, using a filter
+method that takes a line of a logfile as input, and returns
+true if it matches, and false if it doesn't.
+
+There are two possible non-matching (false) conditions; one
+is where the line is a valid httpd logfile entry, but just
+doesn't happen to match the filter (where "" is returned).
+The other is where it is an invalid entry according to the
+format specified in the constructor.
+
+WWW: http://search.cpan.org/search?dist=HTTPD-Log-Filter
diff --git a/www/p5-HTTPD-Log-Filter/pkg-plist b/www/p5-HTTPD-Log-Filter/pkg-plist
new file mode 100644
index 000000000000..fa264d176cc2
--- /dev/null
+++ b/www/p5-HTTPD-Log-Filter/pkg-plist
@@ -0,0 +1,8 @@
+bin/exclude_robots
+lib/perl5/site_perl/%%PERL_VER%%/HTTPD/Log/Filter.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/HTTPD/Log/Filter/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/HTTPD/Log/Filter
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/HTTPD/Log 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/HTTPD 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/HTTPD/Log 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/HTTPD 2>/dev/null || true