aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Kwiki-Archive-Rcs/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2004-07-25 10:08:02 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2004-07-25 10:08:02 +0000
commitb0b180a9ee99ba385ab6bc3b6c987e9d2ffb4abf (patch)
treea6d750ef2e4a1c7d68127f196c0ab6db0d7c3b74 /www/p5-Kwiki-Archive-Rcs/Makefile
parenta02f5224e7f2df33cc5da9f55452cfd414afde12 (diff)
downloadports-b0b180a9ee99ba385ab6bc3b6c987e9d2ffb4abf.tar.gz
ports-b0b180a9ee99ba385ab6bc3b6c987e9d2ffb4abf.zip
Notes
Diffstat (limited to 'www/p5-Kwiki-Archive-Rcs/Makefile')
-rw-r--r--www/p5-Kwiki-Archive-Rcs/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/www/p5-Kwiki-Archive-Rcs/Makefile b/www/p5-Kwiki-Archive-Rcs/Makefile
new file mode 100644
index 000000000000..89105744c389
--- /dev/null
+++ b/www/p5-Kwiki-Archive-Rcs/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Kwiki-Archive-Rcs
+# Date created: Jul 24 2004
+# Whom: Cheng-Lung Sung <clsung@dragon2.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Kwiki-Archive-Rcs
+PORTVERSION= 0.10
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Kwiki
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@dragon2.net
+COMMENT= Kwiki Page Archival Using RCS
+
+BUILD_DEPENDS= ${SITE_PERL}/Kwiki.pm:${PORTSDIR}/www/p5-Kwiki
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Kwiki::Archive::Rcs.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= This port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>