aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Kwiki-Atom
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2004-09-01 03:48:19 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2004-09-01 03:48:19 +0000
commitfd284a06ff63f8a5a4ba5809160fe3692ef91e52 (patch)
tree9ba6673ac18259e6b3a816f254281d65292dbea1 /www/p5-Kwiki-Atom
parentf68c92c00e21f18ec397949b349198962e818a42 (diff)
downloadports-fd284a06ff63f8a5a4ba5809160fe3692ef91e52.tar.gz
ports-fd284a06ff63f8a5a4ba5809160fe3692ef91e52.zip
Notes
Diffstat (limited to 'www/p5-Kwiki-Atom')
-rw-r--r--www/p5-Kwiki-Atom/Makefile36
-rw-r--r--www/p5-Kwiki-Atom/distinfo2
-rw-r--r--www/p5-Kwiki-Atom/pkg-descr8
-rw-r--r--www/p5-Kwiki-Atom/pkg-message9
-rw-r--r--www/p5-Kwiki-Atom/pkg-plist7
5 files changed, 62 insertions, 0 deletions
diff --git a/www/p5-Kwiki-Atom/Makefile b/www/p5-Kwiki-Atom/Makefile
new file mode 100644
index 000000000000..5b60246b5538
--- /dev/null
+++ b/www/p5-Kwiki-Atom/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: p5-Kwiki-Atom
+# Date created: Jul 24 2004
+# Whom: Cheng-Lung Sung <clsung@dragon2.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Kwiki-Atom
+PORTVERSION= 0.04
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Kwiki
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Kwiki Atom Plugin
+
+BUILD_DEPENDS= ${SITE_PERL}/Kwiki.pm:${PORTSDIR}/www/p5-Kwiki \
+ ${SITE_PERL}/XML/XPath.pm:${PORTSDIR}/textproc/p5-XML-XPath \
+ ${SITE_PERL}/XML/Atom.pm:${PORTSDIR}/textproc/p5-XML-Atom
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Kwiki::Atom.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= This port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-Kwiki-Atom/distinfo b/www/p5-Kwiki-Atom/distinfo
new file mode 100644
index 000000000000..fbc847d22a58
--- /dev/null
+++ b/www/p5-Kwiki-Atom/distinfo
@@ -0,0 +1,2 @@
+MD5 (Kwiki-Atom-0.04.tar.gz) = 15bc7051f8708a71434db507c3ca1621
+SIZE (Kwiki-Atom-0.04.tar.gz) = 13309
diff --git a/www/p5-Kwiki-Atom/pkg-descr b/www/p5-Kwiki-Atom/pkg-descr
new file mode 100644
index 000000000000..74401c02a834
--- /dev/null
+++ b/www/p5-Kwiki-Atom/pkg-descr
@@ -0,0 +1,8 @@
+Kwiki::Atom - Kwiki Atom Plugin
+
+This Kwiki plugin provides Atom integration with Kwiki.
+
+For more info about this kind of integration, please
+refer to http://www.xml.com/pub/a/2004/04/14/atomwiki.html.
+
+WWW: http://search.cpan.org/dist/Kwiki-Atom/
diff --git a/www/p5-Kwiki-Atom/pkg-message b/www/p5-Kwiki-Atom/pkg-message
new file mode 100644
index 000000000000..e44122591f63
--- /dev/null
+++ b/www/p5-Kwiki-Atom/pkg-message
@@ -0,0 +1,9 @@
+/* ================================================================= */
+Note:
+ Kwiki-Atom plugin installed! Now you should add
+ to your kwiki in kwiki installation directory:
+
+$ cd cgi-bin/my-kwiki
+$ kwiki -add Kwiki::Atom
+
+/* ================================================================= */
diff --git a/www/p5-Kwiki-Atom/pkg-plist b/www/p5-Kwiki-Atom/pkg-plist
new file mode 100644
index 000000000000..7e9ee0843ac4
--- /dev/null
+++ b/www/p5-Kwiki-Atom/pkg-plist
@@ -0,0 +1,7 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/Kwiki/Atom.pm
+%%SITE_PERL%%/Kwiki/Atom/Server.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Kwiki/Atom/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Kwiki/Atom
+@dirrm %%SITE_PERL%%/Kwiki/Atom
+@unexec rmdir %D/%%SITE_PERL%%/Kwiki 2>/dev/null || true