aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Kwiki-ModPerl
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2005-04-06 08:25:42 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2005-04-06 08:25:42 +0000
commitb20cce15d956c37a39fda19e27bcf4c4b4ca691a (patch)
tree1c19123a08199af9028c66edbe8c4a05f7d97583 /www/p5-Kwiki-ModPerl
parent54e09a4da55199f7a0013b5f191fdaaac5f43ad3 (diff)
downloadports-b20cce15d956c37a39fda19e27bcf4c4b4ca691a.tar.gz
ports-b20cce15d956c37a39fda19e27bcf4c4b4ca691a.zip
Notes
Diffstat (limited to 'www/p5-Kwiki-ModPerl')
-rw-r--r--www/p5-Kwiki-ModPerl/Makefile42
-rw-r--r--www/p5-Kwiki-ModPerl/distinfo2
-rw-r--r--www/p5-Kwiki-ModPerl/pkg-descr3
-rw-r--r--www/p5-Kwiki-ModPerl/pkg-message23
-rw-r--r--www/p5-Kwiki-ModPerl/pkg-plist3
5 files changed, 73 insertions, 0 deletions
diff --git a/www/p5-Kwiki-ModPerl/Makefile b/www/p5-Kwiki-ModPerl/Makefile
new file mode 100644
index 000000000000..7efdb66ba9ae
--- /dev/null
+++ b/www/p5-Kwiki-ModPerl/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: p5-Kwiki-ModPerl
+# Date created: Wed Apr 6 16:30:34 CST 2005
+# Whom: clsung
+#
+# $FreeBSD$
+#
+
+PORTNAME= Kwiki-ModPerl
+PORTVERSION= 0.06
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Kwiki
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Enable Kwiki to work under mod_perl
+
+BUILD_DEPENDS= ${SITE_PERL}/Kwiki.pm:${PORTSDIR}/www/p5-Kwiki
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+.if defined(WITH_APACHE2)
+BUILD_DEPENDS+= ${LOCALBASE}/libexec/apache2/mod_perl.so:${PORTSDIR}/www/mod_perl2
+pre-patch:
+ @${REINPLACE_CMD} -e 's|mod_perl|Apache2::mod_perl|g' ${WRKSRC}/Makefile.PL
+.else
+BUILD_DEPENDS+= ${LOCALBASE}/libexec/apache/libperl.so:${PORTSDIR}/www/mod_perl
+.endif
+
+MAN3= Kwiki::ModPerl.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= This port requires perl 5.8.x or later. Install lang/perl5.8 then try again
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-Kwiki-ModPerl/distinfo b/www/p5-Kwiki-ModPerl/distinfo
new file mode 100644
index 000000000000..dc07e7949470
--- /dev/null
+++ b/www/p5-Kwiki-ModPerl/distinfo
@@ -0,0 +1,2 @@
+MD5 (Kwiki-ModPerl-0.06.tar.gz) = b27b50056ba8b2557ce808ec84ebe222
+SIZE (Kwiki-ModPerl-0.06.tar.gz) = 9726
diff --git a/www/p5-Kwiki-ModPerl/pkg-descr b/www/p5-Kwiki-ModPerl/pkg-descr
new file mode 100644
index 000000000000..207633d9103a
--- /dev/null
+++ b/www/p5-Kwiki-ModPerl/pkg-descr
@@ -0,0 +1,3 @@
+Kwiki::ModPerl - enable Kwiki to work under mod_perl
+
+WWW: http://search.cpan.org/dist/Kwiki-ModPerl/
diff --git a/www/p5-Kwiki-ModPerl/pkg-message b/www/p5-Kwiki-ModPerl/pkg-message
new file mode 100644
index 000000000000..24679822ada0
--- /dev/null
+++ b/www/p5-Kwiki-ModPerl/pkg-message
@@ -0,0 +1,23 @@
+/* ================================================================= */
+Note:
+ Kwiki-ModPerl plugin installed! Now you should modify
+ your Apache configuration:
+
+ <Location /kwiki>
+ SetHandler perl-script
+ PerlSetVar KwikiBaseDir /path/to/webroot/kwiki
+ PerlHandler +Kwiki::ModPerl
+ </Location>
+
+ If you have a custom lib directory for your Kwiki:
+
+ <Perl>
+ use lib '/path/to/webroot/kwiki/lib';
+ </Perl>
+
+ If you're using mod_perl2, please add the following line
+ into your httpd.conf:
+
+ PerlModule Apache2
+
+/* ================================================================= */
diff --git a/www/p5-Kwiki-ModPerl/pkg-plist b/www/p5-Kwiki-ModPerl/pkg-plist
new file mode 100644
index 000000000000..7c45b004af7f
--- /dev/null
+++ b/www/p5-Kwiki-ModPerl/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/Kwiki/ModPerl.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Kwiki/ModPerl/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Kwiki/ModPerl