aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Kwiki-RecentChangesRSS/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-07-24 01:47:02 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-07-24 01:47:02 +0000
commit3366b1b7de5168a09b9c675f06fa98fdd2dbe92d (patch)
tree0be08357c2d5e306cc4b912d96c7b4aea2e1cb51 /www/p5-Kwiki-RecentChangesRSS/Makefile
parent66c641b145f3708610c779c3745f091182342980 (diff)
Notes
Diffstat (limited to 'www/p5-Kwiki-RecentChangesRSS/Makefile')
-rw-r--r--www/p5-Kwiki-RecentChangesRSS/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/www/p5-Kwiki-RecentChangesRSS/Makefile b/www/p5-Kwiki-RecentChangesRSS/Makefile
new file mode 100644
index 000000000000..86ffce62b0d6
--- /dev/null
+++ b/www/p5-Kwiki-RecentChangesRSS/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Kwiki-RecentChangesRSS
+# Date created: Jul 24 2004
+# Whom: Cheng-Lung Sung <clsung@dragon2.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Kwiki-RecentChangesRSS
+PORTVERSION= 0.02
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Kwiki
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@dragon2.net
+COMMENT= Kwiki RSS Plugin
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${SITE_PERL}/XML/RSS.pm:${PORTSDIR}/textproc/p5-XML-RSS
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Kwiki::RecentChangesRSS.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= This port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>