aboutsummaryrefslogtreecommitdiff
path: root/www/p5-LWP-Protocol-PSGI
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2013-01-20 23:03:34 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2013-01-20 23:03:34 +0000
commit176e4c68ca3b246e2933e5051032c6d3f04ba18c (patch)
treef96e2bc4110211151f5815626c74abced747ea0c /www/p5-LWP-Protocol-PSGI
parent061eac8187fb8f90c2d172f03f5996e50e0c0e39 (diff)
downloadports-176e4c68ca3b246e2933e5051032c6d3f04ba18c.tar.gz
ports-176e4c68ca3b246e2933e5051032c6d3f04ba18c.zip
Notes
Diffstat (limited to 'www/p5-LWP-Protocol-PSGI')
-rw-r--r--www/p5-LWP-Protocol-PSGI/Makefile24
-rw-r--r--www/p5-LWP-Protocol-PSGI/distinfo2
-rw-r--r--www/p5-LWP-Protocol-PSGI/pkg-descr5
-rw-r--r--www/p5-LWP-Protocol-PSGI/pkg-plist4
4 files changed, 35 insertions, 0 deletions
diff --git a/www/p5-LWP-Protocol-PSGI/Makefile b/www/p5-LWP-Protocol-PSGI/Makefile
new file mode 100644
index 000000000000..f80c21e459f5
--- /dev/null
+++ b/www/p5-LWP-Protocol-PSGI/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= LWP-Protocol-PSGI
+PORTVERSION= 0.04
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension to override LWP HTTP/HTTPS backend with your PSGI app
+
+RUN_DEPENDS= \
+ p5-Guard>0:${PORTSDIR}/devel/p5-Guard \
+ p5-Plack>0:${PORTSDIR}/www/p5-Plack \
+ p5-libwww>=5:${PORTSDIR}/www/p5-libwww
+BUILD_DEPENDS= ${RUN_DEPENDS}
+TEST_DEPENDS= \
+ p5-LWP-Protocol-https>0:${PORTSDIR}/www/p5-LWP-Protocol-https
+
+PERL_CONFIGURE= yes
+
+MAN3= LWP::Protocol::PSGI.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-LWP-Protocol-PSGI/distinfo b/www/p5-LWP-Protocol-PSGI/distinfo
new file mode 100644
index 000000000000..508f429ec8cf
--- /dev/null
+++ b/www/p5-LWP-Protocol-PSGI/distinfo
@@ -0,0 +1,2 @@
+SHA256 (LWP-Protocol-PSGI-0.04.tar.gz) = d30f7919fb1e1887aca581345450d25cc570671ef566bbba269d2b0e298e395e
+SIZE (LWP-Protocol-PSGI-0.04.tar.gz) = 23489
diff --git a/www/p5-LWP-Protocol-PSGI/pkg-descr b/www/p5-LWP-Protocol-PSGI/pkg-descr
new file mode 100644
index 000000000000..5ecbb6eb68e7
--- /dev/null
+++ b/www/p5-LWP-Protocol-PSGI/pkg-descr
@@ -0,0 +1,5 @@
+LWP::Protocol::PSGI is a module to hijack any code that uses
+LWP::UserAgent underneath such that any HTTP or HTTPS requests can be
+routed to your own PSGI application.
+
+WWW: http://search.cpan.org/dist/LWP-Protocol-PSGI/
diff --git a/www/p5-LWP-Protocol-PSGI/pkg-plist b/www/p5-LWP-Protocol-PSGI/pkg-plist
new file mode 100644
index 000000000000..f5b5f5b39ced
--- /dev/null
+++ b/www/p5-LWP-Protocol-PSGI/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/LWP/Protocol/PSGI/.packlist
+%%SITE_PERL%%/LWP/Protocol/PSGI.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/LWP/Protocol/PSGI
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/LWP/Protocol